SaabCentral Forums banner

21 - 40 of 54 Posts

Registered
Joined
1,082 Posts
But why it wouldnt do it with engine off then !馃
I'm not sure, yet. I'm also not sure what else would cause the on/off times to be so precise.

EDIT: Ah OK, so not UEC.
 

Registered
Joined
22 Posts
Discussion Starter #25
ground its OK.篓篓

Is there any other light control unit in the car that may have failed and, for example, misjudges with the engine running that the headlight is OK?
 

Registered
Joined
8,173 Posts
Have you tried to swap whole lights, do issue stay?
 

Registered
Joined
24 Posts
Here's a segment from the (admittedly) limited online wis - Xenon lamp operation 鈥 9-3 2006 | SAAB Workshop Information System Online

It looks as if the system is attempting to reignite as if the bulb has gone out during operation, this normally indicates an issue in the ballast from what I've seen however here as they are separate units it could be related to how they communicate, or if the signal to turn on the ballast is intermittent. I'd imagine the issue is in one of the wires between the ballast and ignitor or the sustained control signal.

Apparently the ballast's like to collect water, and I imagine that can cause a whole host of weird erratic issues, although be careful working around the high voltage HID systems, you will not be able to safely measure the HID voltage/amperage with common tools, and the high voltage can be dangerous.
 

Registered
Joined
959 Posts
Have you tried the actual switch? 9-5 has similar issues, usually ends up being the headlight switch.
 

Registered
Joined
8,173 Posts
What?
Headlight switch is ONLY switch, it will not cause flickering on just one headlight.
 

Registered
Joined
959 Posts
Anything is possible. I'd check the relays too.
 

Registered
Joined
959 Posts
Then it's a module issue unfortunately. There's always a relay and switch.. in this case it'll be built into the module- but they're there.
 

Registered
Joined
8,173 Posts
If the semiconductor switch is a relay, then yes
Yes i tried it. There is still a problem on the right. So both headlights are fine
So you have either bad wiring loom or bad UEC.
 

Registered
Joined
1,082 Posts
...and it would appear UEC is ruled out by post #21.
 
  • Like
Reactions: Hus_sho

Registered
Joined
4 Posts
I have problem at my 9-3 aero convertible right xenon headlight. It start flickering after start engine. When engine is off it shine normally. I have trayed everything (change bulb, ballast and at end put there another complete xenon headlight -the same problem) . Every time it start flickering after I start engine. It will light up normally approximately 10 minutes after starting. Problem isn't at headlight (I was trayed another one) but I don't know where. When I stop engine it star shine normally
Dang!! It looks like you connected it to a turn signal or emergency blinker circuit. And due to the incompatibility with the flasher, it's operating erratically.
 

Registered
Joined
22 Posts
Discussion Starter #40
Dang!! It looks like you connected it to a turn signal or emergency blinker circuit. And due to the incompatibility with the flasher, it's operating erratically.
Did you see the attached video? What you write is nonsense! I did not change anything in the connector, it is definitely a defect. WHEN THE ENGINE IS OFF, THE LIGHTS LIGHT ON NORMALLY
RIGHT FLASHES AFTER STARTING, IT STOP FLASHING ABOUT 10MIN AFTER THE ENGINE WILL START
 
21 - 40 of 54 Posts
Top