SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have the c 0141 code for my 9-5. It says increase pressure valve. I was advised by the mechanic that I needed a new unit. I have tried looking for information on repairing them so that I can get the abs lights off my dash after having the module repaired.
 

·
Registered
Joined
·
1,327 Posts
I haven’t come across that error myself, but would always suspect a mechanic who says “replace the whole unit”. In the case of ABS it’s often the electronic unit on the side of the pump (6 small torx screws) which is faulty and can be refurbished. However the refurbishers usually prefer to have the whole unit, pump and ECU, sent to allow proper calibration etc.

In the UK it would cost me £120 for this job so about 150 of your American dollars.

If you do replace either the whole thing or just the ECU, ensure you have exactly the same part numbers.

Not sure what you mean by “increase pressure valve”.

Doug
 

·
Registered
Joined
·
721 Posts
I haven’t come across that error myself, but would always suspect a mechanic who says “replace the whole unit”. In the case of ABS it’s often the electronic unit on the side of the pump (6 small torx screws) which is faulty and can be refurbished. However the refurbishers usually prefer to have the whole unit, pump and ECU, sent to allow proper calibration etc.

In the UK it would cost me £120 for this job so about 150 of your American dollars.

If you do replace either the whole thing or just the ECU, ensure you have exactly the same part numbers.

Not sure what you mean by “increase pressure valve”.

Doug
Good advice. it is usually the control box.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
I had the module repaired and sent it back when my speedometer only came back repaired. I had it checked at two locations. My mechanic from the dealer had originally told me it was the actual pump but i wasnt sold on that until I sent the module off and got a second opinion. Thats where I was given the C0141 code.
 

·
Registered
Joined
·
721 Posts
I had the module repaired and sent it back when my speedometer only came back repaired. I had it checked at two locations. My mechanic from the dealer had originally told me it was the actual pump but i wasnt sold on that until I sent the module off and got a second opinion. Thats where I was given the C0141 code.
Where did you get the module repaired? I would only trust BBA Reman in MA. http://www.bba-reman.com/us/index.aspx

They are a large international company that have great resources. I have no interest in them, just a happy customer.

They repair it and bench test it and give you a lifetime warranty. They have done a couple modules for me and they work fine.

I had a friend who took a 2003 9-5 module to some local guy in LA and he could fix the Speedo but that was it. waste of time.......pick a module repair shop that knows what they are doing.

By the way it is rarely pump. The dealer used to have them replace both at the same time. That may be where his thinking is coming from.

If BBA did not do the repair, take out the module and send it to them. You can drive the car without the module.

Other wise you are wasting you time with dubious repair advice.
 
1 - 6 of 6 Posts
Top