SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
i recently purchased a 2004 saab 9-3 with 85k miles. the car ran perfect until earlier today it started jerking on the highway. at first i felt like the transmission was slipping b/c as i was giving it gas it would start like vibrating (felt like i was going over rumble strips). it started off as a little slip i guess, then eventually got worse to the point where if i continued to give it throttle as it downshifted, it would cause this vibration. i got worried, and took a local road rest of the way home. i was testing it out and it only seemed to vibrate/jerk like this wen the turbo gauge would get really close to the red strips. if the turbo gauge was halfway then the car ran and shifted fine...
so i started leaning towards a turbo b/c i know there is a slight whistle coming from it, and i figured it just went on me; but at full throttle the power seemed to be there; i am very stumped by this problem; also the check engine light would flash and go away; it stayed on once and displayed misfire on cylinder 1, which i later reset with my scan tool; but it never came back on.
please if anyone has any thoughts on this, let me know asap
thanks
 

·
Registered
Joined
·
864 Posts
Most likely it is the ignition coil or spark plugs. However, have it checked immediately.
Flashing CEL indicates serious malfunction.

Here, check this out:
http://www.youtube.com/watch?v=q20ThsqO36s

Is your problem similar?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
hmm i watched the video, and it seems very similar the flashing check engine light after i let go of the throttle; mine stops flashing after a few blinks; and im not sure about the noises and it sounded like a thump at the end of the video, but all i know is that the noise my car makes is almost same as if you went over rumble strips; what was the problem with your car?
 

·
Registered
Joined
·
864 Posts
hmm i watched the video, and it seems very similar the flashing check engine light after i let go of the throttle; mine stops flashing after a few blinks; and im not sure about the noises and it sounded like a thump at the end of the video, but all i know is that the noise my car makes is almost same as if you went over rumble strips; what was the problem with your car?
Your engine struggles to deliver power because of the misfire, thus the shaking.I had shaking problem with my previous car (Ford) to the point that the engine got blown (my pure negligence), so again, have it checked and fixed asap.

Do you know the service history of your vehicle?
 

·
Registered
Joined
·
4,509 Posts
it is a coilpack failure.

Bring it to the dealer, they'll plug in the tech 2 and take it for a spin.
Let you know which cylinder(s) are misfiring and list the options for fix
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
yea there was a code for misfire on cylinder one. i dont have previous service history of the car. and yea i did clean the engine bay not too long ago at the car wash with that engine clean option.... do you think that was the cause?? and also when the car is on park, then the engine seems to run excellent. when you hold the car on drive then the rpms seem to drop a little and then pick back up, and it sounds like a little misfire. but i dont understand y its not doing it in park and neutral?
 

·
Registered
Joined
·
248 Posts
just want to know

did you do the engine clean with the engine on or off
I would never do the engine clean with a power wash but that's just me
 
1 - 9 of 9 Posts
Top