SaabCentral Forums banner

21 - 30 of 30 Posts

·
Registered
Joined
·
33 Posts
Nothing but static on both AM/FM except sometimes a very close station comes in crystal clear - so everything works...sort of...

Any way to test the 'antenna booster' and/or the 'antenna amplifier', assuming the wiring is ok?
 

·
Registered
Joined
·
33 Posts
Ok, sorry to beat up again on this dying horse...my radio works, but I only get a station or 2 (both AM & FM) if I'm within like 1 mile of the broadcast antenna - beyond that, just static...so is this 'probably' an antenna 'booster' and/or 'aerial amplifier' issue? I can't imagine it could be a cable/wire if it does actually work...

Dan
 

·
Super Moderator
Joined
·
9,237 Posts
Ok, sorry to beat up again on this dying horse...my radio works, but I only get a station or 2 (both AM & FM) if I'm within like 1 mile of the broadcast antenna - beyond that, just static...so is this 'probably' an antenna 'booster' and/or 'aerial amplifier' issue? I can't imagine it could be a cable/wire if it does actually work...

Dan
Assuming you have a 4D, here is some basic info about the system and how it works to get you started. When it comes down to it, it's either 1 of the 2 electronic components or a short in the rear window antenna.

 

·
Super Moderator
Joined
·
9,237 Posts

·
Registered
Joined
·
50 Posts
Antenna trouble.

wow. i found this thread because my new to me 07 9-3 ss has these issues with radio reception.

what do i find when i pull the panel off?

the lug attached to the glass is barely attached. and my moving wires around finished it off.

now i need to find a way to reattach it.

and then find some used parts in a junk yard and try those.
 

·
Registered
Joined
·
33 Posts
Location of 'Aerial amplifier'?

Hiy'all, can anyone tell me where the 'Aerial amplifier', Saab part 12758653 is located in the 2006 9-3 convertible? Since I occasionally get an Am or Fm station when I'm 'close' to the broadcast antenna, I think I've pinned down that its this amp that needs replacing. I've already replaced the 'antenna amplifier' at the base of the mast-style antenna - didn't do anything to solve the problem...thanks, Dan


https://drive.google.com/file/d/0B0L...ew?usp=sharing
 
21 - 30 of 30 Posts
Top