SaabCentral Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
I needed to replace my instrument pane. Got it done! 89 turbo vert.

But now, reassembling the dash panel I failed to take a picture of the wiring on the heat distribution switch before i took it apart.

There are six terminal...or is it four? I don't want to cross wires and burn something up. I though the wires would just settle in place easily. Nope didn't happen. Does any one have a picture of the switch, or a hand sketch of what wire goes where ?

Man, I am in deep stuff with my family.

Help , please
 

·
Registered
Joined
·
73 Posts
Here's my '91. There's 4 connectors 2 on either side of the cig. lighter. The heat distribution switch has vacuum hoses to it. Not sure if this helps...


Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
73 Posts
Oh yeah that... I didn't take a picture of it either, maybe that's why mine doesn't work!

Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
9,347 Posts
The fan does weird things if it's not wired right. I've never actually used this particular one, but it looks right. :)
 

·
Registered
Joined
·
73 Posts
I'll have to check it out. My fan seems to run the same speed in all positions. I don't remember messing with it though.

Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
9,347 Posts
Yeah, that's one of the symptoms that happens when that switch isn't hooked up right. It's from the '70s, it can't be that complicated and yet I've never figured out how it's actually wired. ;)
 

·
Registered
Joined
·
73 Posts
This is the only picture I have showing that wiring and the half that's connected seems to match your picture. The mounting screw on the right is my reference. But I don't think I ever had 3 fan speeds even before I messed with the dash. I looked at the Bentley couldn't find the air distribution on the schematic. It was listed as 150???


Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #9 ·
This is the only picture I have showing that wiring and the half that's connected seems to match your picture. The mounting screw on the right is my reference. But I don't think I ever had 3 fan speeds even before I messed with the dash. I looked at the Bentley couldn't find the air distribution on the schematic. It was listed as 150???


Sent from my SM-G965F using Tapatalk
hmmmm your bottom three contacts have nothing connected. See the picture above of just the selector switch and wire. I'm going outside now to try mine
 

·
Registered
Joined
·
73 Posts
hmmmm your bottom three contacts have nothing connected. See the picture above of just the selector switch and wire. I'm going outside now to try mine
That was an in process picture, I wasn't finished yet...

Sent from my SM-G965F using Tapatalk
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #12 ·
I think this is what you want.
Thank You Thank You Thank YOU! this was good. But funny thing. The top wires are cable tied together. In that top group there was also a thin gauge grey wire. I didn't try to connect it since the fans worked just fine. Hmmmm.
 

·
Registered
Joined
·
9,347 Posts
I think that extra wire may be for other markets, or maybe for cars without AC or something. It's present on all c900s, and I've never seen it connected. Probably a wiring diagram would lend some info, but I've never cared to look. In the photo I posted, that grey wire is wrapped up in the duct tape.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #14 ·
I think that extra wire may be for other markets, or maybe for cars without AC or something. It's present on all c900s, and I've never seen it connected. Probably a wiring diagram would lend some info, but I've never cared to look. In the photo I posted, that grey wire is wrapped up in the duct tape.

ah ha. wasn't looking for that wire and didn't notice it.

Everything works fine thanks John in Baltimore
 
1 - 14 of 14 Posts
Top