SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter · #1 ·
I am trading in my 2002 SS tid tomorrow for a new Aero convertible and have to drive down from Chester to London - approx 200 miles.

I have had my car since new and the warranty ends next week (hence new car tomorrow), but after 3 years of NO problems I think my turbo has decided to take a break...

When I put my foot down there's an air noise (not the usual whilstle), and a substantial lack of power (I'm talking 0-30 in like 7 seconds). I think maybe a pipe into or out of the turbo has come loose? I've looked under the bonnet but to be honest I've no idea what I'm doing and ended up just burning myself.

Hopefully I can get the car to London tomorrow or I'm going to be fuming.

Interestingly though the car hasnt gone into limp mode..fingers crossed it will get me there tomorrow.
 

·
Registered
Joined
·
1,234 Posts
at the very least, look for a large black hose going into or coming out of the intercooler/radiator area. it may be located very low in the engine bay...that would be a shame to trade in a car or pay to have a hose reconnected.
 

·
Registered
Joined
·
248 Posts
Discussion Starter · #3 ·
Nothing seems to be loose, although I'll wait for it to cool down before prodding a few hoses..

Do you think it is safe to drive? I guess it is just a simple case of a loose hose, and wont affect the engine, otherwise it should go into 'limp' mode?
 

·
Registered
Joined
·
1,101 Posts
There was a recent post similar to this. It sounds like the hose on to the intercooler. Others that had had this problem, claimed to be able to see the hose from underneath the car. (That was on petrol models I think).

Should be safe (if slow!) to drive.
 
1 - 4 of 4 Posts
Top