SaabCentral Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
954 Posts
Discussion Starter #1 (Edited)
Where to get a "new" gauge cluster?

Where might one find a new gauge cluster? mine is all messed up. gas hardly works. temp barely, speedo bounces at low speed. RPM have to hit the dash. and odometer never worked in 7 years.
 

·
Registered
Joined
·
1,470 Posts
I just bought one for my 9-5 lastnight..its the one with the turbo guage built in..only cost me 29+ shipping. Got it from ebay
 

·
Registered
Joined
·
10,081 Posts
davidlytle said:
Where might one find a new gauge cluster? mine is all messed up. gas hardly works. temp barely, speedo bounces at low speed. RPM have to hit the dash. and odometer never worked in 7 years.
I'd be very tempted to try cleaning the multiplugs first - speaker out, reach in and unplug 'em (one either side of the cluster, vertically), spray with contact cleaner, replug.
 

·
Registered
Joined
·
18,382 Posts
Yeah all of your problems look unrelated to the cluster itself.
 

·
Registered
Joined
·
254 Posts
Outback Cluster Pluck

Pardon the humor :lol: . Actually look outback of your local independent Saab shop or even SAAB GM shop. I have had good luck locally with getting permission to pull parts off crashed 900 Saabs. Usually I give the shop some token of appreciation for the parts. If this doesn't work, I have a 900 Turbo cluster set. I am not sure if it would match up to your connectors. The boost gage would be null and void obviously.
Good luck!
 

·
Registered
Joined
·
954 Posts
Discussion Starter #7
thanks for the replys. But the odometer does not work. I took it apart and it worked for about 2 miles then stopped again. I want to get a gauge cluster that works. Which is why I want a "new" cluster not a used one. I might just have to pull a used one from a 87 locally. I was wondering if they still make them.
 

·
Banned
Joined
·
5,841 Posts
Bounce speedo needle means the cable clip is broken, faulty fuel sender could account for poor or no readings and your temperature sender could be wonky as well, it can happen but its not typical for the binical to stop working all in one go, check the other stuff first I say.
 

·
Registered
Joined
·
10,081 Posts
davidlytle said:
thanks for the replys. But the odometer does not work. I took it apart and it worked for about 2 miles then stopped again. I want to get a gauge cluster that works. Which is why I want a "new" cluster not a used one. I might just have to pull a used one from a 87 locally. I was wondering if they still make them.
You can change the speedo/odo separately within the cluster.

If you can still buy one from a main stealer, I can only dread the price...
 

·
Registered
Joined
·
954 Posts
Discussion Starter #10
Ill try the contact cleaner, and call saab to see about a new odometer cluster. I gas guage will sometimes not work so I reach in through the radio hole and push on the console and it will show more gas like 3/4 then when I let go it will go down to 1/4 or half. really weird thats why I think its the gauge. its 20 years old.
 
1 - 10 of 10 Posts
Top