SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So, I have a 2001 9-5 SE V6 with 120K miles. I love this car. Last June I had to park it while I was out of town for 6 months. When I got back it wouldn't start. I wasn't able to get a new battery in it and get her going before we got some good snow. Fast forward to April of this year, new battery and the idler pulleys seemed to be seized. The belt spun, smoked, caused a huge noise. I tried loosening them and spraying them, but I'm no mechanic and decided it needed a tow. My dog had also chewed through the seatbelt while I was doing this so I needed a new seatbelt installed. The SAAB guy I used to use is out of business so I went to a local shop thinking I would just get them to replace the pulleys and maybe the belt and take it to someone who specialized when I could drive it.

WELL...6-weeks later and the guy still hadn't done what I was asking to be done. When he towed the car he was able to start it up at the shop saying the pulley wasn't seized anymore. I thought great! Can you do an oil change and give me an estimate on other things that should be done since it was sitting. I asked about just changing the pulleys and belt anyway and kind of got the run around. 6-weeks and all he did was an oil change. THen said it was leaking oil from near the turbo (which was replaced 2 years ago), need exhaust, and he wouldn't sink money into it. Oh and he couldn't change the seatbelt with the one I got from the junk yard, not sure why. I've been out of town again so I didn't push him too much, but when he didn't even have the estimate done. I'd had it. I figured I could try installing the seatbelt and get it to someone for some real TLC.

He towed it back to my house when I wasn't home, I checked the oil, which was full and I didn't see a leak or drip anywhere, and I started it up. Well now the check engine light is on. I open up the hood to do some "looking" and notice this hose is not connected to anything! It is connected to I guess a fan on the side, but then I can't tell if it was cut or came off of something.

Help please. My last SAAb ran to 230K and I was really hoping to get a few mores years out of her with some TLC.
 

Attachments

·
Registered
Joined
·
17 Posts
That hose is not connected to anything,it just sits like that behind the headlight....and there is another one coming from the transmission as well that is not connected to anything,if you see it don't get alarmed.
 

·
Registered
Joined
·
308 Posts
That is the lower hose connected for the SAI pump - Secondary Air Injection pump
 

·
Registered
Joined
·
2,078 Posts
Is that the breather hose? Looks like it may be. If it is it doesn't connect to anything.
 
1 - 5 of 5 Posts
Top