SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
Had a good look through the forums but haven't seen the answer. Where exactly is the O2 sensor/lambda and how can I clean it? (CE light on intermitently and think it's the cause)
Thanks....
 

·
Registered
Joined
·
896 Posts
Exhaust manifold toward the front right corner of the car. I've heard that you can use a torch to clean them but have never actually done it. New generic ones are cheap enough. Alternately, before you go removing it you can test it if you have a digital multimeter. Run the car and after it gets to operating temp, pull back the rubber where the O2 sensor plugs into the wiring harness. Check for a rapid flucuation of 0-.5 volts. (This is from memory, someone correct me if I'm wrong plz)
 

·
Registered
Joined
·
9,170 Posts
It's under the elbow of the exhaust, down by the battery heatshield.

Found this from someone with an LPT:

Dhanda said:
if your sensor has 3 wires one is for the sensor, the other two are 12v live and earth, these are for the heater element which heats the o2 sensor to operating temp. my culprit was the earth and ended up cleaning the earth points on the top front of the cylinder head as thats were it ends up and light has never come on again. By the way i think the live is no 1 fuse.
OK, how about this for the perfect thread at this point :cheesy: :

http://www.saabcentral.com/forums/showthread.php?t=17523&highlight=testing+lambda+sensor

And one more:

http://www.saabcentral.com/assets/downloads/lucascu14.zip

Howzat :D
 
1 - 4 of 4 Posts
Top