SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
OKay my Saab is missing a PCV Check Valve With Hose. I bought a new one but now just don't know where it goes to, I know it starts from the red circled in the picture, but where does it end? Can someone please help, maybe draw on the picture showing me how. Also what goes in the green circled in the picture? Thank you.
 

Attachments

·
Registered
Joined
·
18,949 Posts
The red one goes to the oil trap. See step 21 in the TSB below. AFAIR, nothing goes to the green circle area - see step 20.

http://www.genuinesaab.com/psi/files2/tsb210-2418 ed4 en.pdf

I would really, really suggest you order the PCV #6 update kit from Saab, or eeuroparts.com, or Genuine Saab, and install it. You should not run a T7 without it. It will replace all those hoses and get your PCV system in order. If some of them were missing, I'd be extra concerned and install quickly.
 

·
Registered
Joined
·
337 Posts
The one circled in green has nothing to do with the PCV system. That is a vacuum line. I also see no brake booster vacuum lines in your picture either.

Did you just purchase this car in this condition? Seems to be some fairly serious issue if all these hoses blew off the throttlebody and intake pipe and just disappeared.

Here is a pic of what the area should look like. Your hose connection circled in green should have a rigid plastic molded vacuum line coming out of it. If it is not connected it should be very very very easy to find.

http://i863.photobucket.com/albums/ab195/cs696969/DSC00018.jpg

If you find all the hoses and reconnect them you will want to figure out what caused them to do so in the first place.
 

·
Registered
Joined
·
18,949 Posts
Oh yeah... the brake booster line. Forgot about that. That will teach me to do arm chair mechanical work (it was pouring rain outside and an actual peek wasn't on the agenda)
 

·
Registered
Joined
·
1 Posts
Confused

I just purchased a 2006 Saab 9-5. Love the car! Problem is, i think the person who I bought it from thought the car was a hot rod. He didn't take care of it. In the above picture I am experiencing similar problems. The hose from the throttle body that connects to a spark plug has come off of its hose, and I also do not have a line going to the green circled area in the picture. I could really use some help!
 
1 - 7 of 7 Posts
Top