SaabCentral Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1 (Edited)
So I pulled my radio, hoping I could fix the wonky-volume problem I've been having - tightened all the screws, made sure all connections were tight, and soldered a loose connection in the back.

Plugged it back in, and go to enter my radio code...2_2_...except my '2' button isn't working now. Other five work, just not the one I need.

Huh. It's always something, isn't it? :roll:

Tried all combinations of pulling fuses, cycling power, and no joy.

After an hour of futzing with it, I held down the 'BAND' button while turning the power on, and the radio sprang to life! Don't know if this is normal, or if my possessed deck just thought it would throw one my way.

The radio appears to function perfectly now (except the '2' button)...and the volume control works. Time will tell if the 'fix' took.
 

·
Registered
Joined
·
94 Posts
Hay dude I hope it works out for you. I do know computer Keyboards, Mouse Power button and so on. With a computers have the same problem some grit get under it and you have to press it hard. Or take the key out and clean under it due to dust and junk under it. I think you might want to add this to http://www.saabcentral.com/forums/showthread.php?p=1051964 Name Radio Code tutorial.

What I do know you have a short or something stuck. Short if you spilled something like a drink that make a direct connect where it disable the key.

Anything to get there stereo working for free is a good thing.
 
1 - 2 of 2 Posts
Top