SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
99 V6 with 103K. Car ran fine last night and this morning its dead. Barely any juice to be found. I get a clicking sound when I turned the key and very dim lights on the dash. So I think, OK, dead battery (even though its under 7 months old). I put the charger on and it says full charge. Next, I pit the charger on high and tried. Dash lights came on and it barely turned over. I added a jump from my other car and it started right up. All the dash lights stayed on and I couldn't get it out of gear. After 3 minutes of idling it died again.

Anybody have a clue as to what's happening?
 

·
Registered
Joined
·
3,951 Posts
When it started; Did you get the CEL? Do you have a code reader?
 

·
Registered
Joined
·
106 Posts
Have your alternator checked.If it started on the jump and died shortly after,sounds like it's only running off the battery.Battery can still show full charge but have a bad cell.I would try taking the battery to a local parts store first and have tested or throw one in you know is good to test before testing alt.I recently went through this on my sons car.
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #5 ·
First - thanks to everybody who replied. I wish I could give back more than I take.

I pulled the battery and it did take a charge. So I left it on overnight and it started right up and ran great. So how do I check the alternator? Just take it to a mechanic? I have a cheap multimeter so I can poke around with that too.
 

·
Registered
Joined
·
106 Posts
To test the alternator, Start the car and while it is running pull the positive side of the battery cable off and if it keeps running alternator is fine.I'm no good with electrical but you could find out what it is supposed to be putting out for amps/watts to make sure it is charging the battery as it should. Glad to hear your on the right track!
 
1 - 6 of 6 Posts
Top