SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
OK, so my 2010 9-3 with 106,000 miles...just had the condenser replaced this week, but I don't think that's got anything to do with this but want to throw that fact in...

My son is driving it yesterday and the CEL comes on. Car keeps running, appears to be in limp home mode but actually drives pretty normally except for no to low boost.

Gets it home, I start looking at it. The speedo is at 15 mph, even when the car is off. Road speeds are now +15 mph at all times.

I pulled the negative term off the battery, let it sit and put it back on. Cleared the CEL light, and boost came back to normal for a couple minutes, then seemed to taper off again. Still no CEL.

I also noticed the power windows don't do one touch up anymore (maybe just need a reset, I know how to do that).

The battery is 4 years old. Could all this be due to needing a battery? I tested it and it's showing 12.5 volts at rest- I thought that meant it was OK?

Appreciate any thoughts. Thanks!

Brian
 

·
Registered
Joined
·
7,687 Posts
So you do not have any issue now.
Window reset: Press window down until window is lowered, release button after 5 sec.
Press window up until window is raised fully, release button after 5 sec.
Press window down until window is lowered, release button after 5 secs.
Press window up until window is raised fully. Now you should hear "bim".
Window is reset.
Repeat with all windows.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
With the windows, no. But the speedo is still resting at 15 mph when the car is off. Thanks!
 

·
Registered
Joined
·
7,687 Posts
Speedo could reset itself when you unhook battery again.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Hey Mimmi- one last question for you since you seem to have a good handle on this stuff- I mentioned above that I just replaced the A/C condenser. Now, 3 days later, it's blowing hot air again. Would a failing ECU have any effect on air conditioner operation?

Thanks!
 

·
Registered
Joined
·
7,687 Posts
Yes.
AC needs ALL cooling fan speeds working and ECU controls cooling fan speeds.
 
1 - 6 of 6 Posts
Top