SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter #1
My engine cranks quite slow-moderately slow before it finally starts up. I know the battery has been weak and I will need to get a new one before the start of the winter. However, I was wondering if the starter was just plain tired? What say you? The distributor cap and rotor button seems ok, and isn't pitted or worn.



91 900 turbo 174,000 at
 

·
Registered
Joined
·
95 Posts
You could have your battery tested at autozone. Does it turn over normally with a jump start? If so, it's not the starter. Also, put a meter on your battery terminals while running, if you get around 14v, the charging system is ok. Let us know how you make out.
 

·
Registered
Joined
·
21,583 Posts
I replaced the starter unit in the '96 at 150K miles as the solenoid was failing, but when working, the speed was fine.

Now we have a car 5 years older with yet more miles..
Do the battery/alternator service - the starter is just another motor in the system, when it fails, you will know..
If this were mine, I would renew the starter brushes (with all those miles), unless this was done by the previous owner at 100K miles or so...
 

·
Registered
Joined
·
151 Posts
Discussion Starter #4
Thanks! Yeah it appears to be the battery. I picked up a good diehard with high amps, particuarly one with a higher ratio of CCA. :)
abaton6 said:
You could have your battery tested at autozone. Does it turn over normally with a jump start? If so, it's not the starter. Also, put a meter on your battery terminals while running, if you get around 14v, the charging system is ok. Let us know how you make out.
 

·
Registered
Joined
·
21,583 Posts
I like the idea of a higher quality load tester than the one I now use(HF $15)..But it works, my 3 year old size 42 battery, a WalMart cheapie , is now marginal..

The 4year old battery in the Honda easily passes..some "Saab" batteries have been good past 7 years !!

Wise to have bought the DieHard, 91900turbo..:cheesy:
 

·
Registered
Joined
·
95 Posts
Thanx for the follow up. We all learn from other's experiences

91900turbo said:
Thanks! Yeah it appears to be the battery. I picked up a good diehard with high amps, particuarly one with a higher ratio of CCA. :)
 

·
Registered
Joined
·
21,583 Posts
abaton6 said:
Thanx for the follow up. We all learn from other's experiences
How true, and we were able to post all of this on the "wrong" section (a '91 in the '94 to '02 area) and the moderators never caught this....lol...lol...:cheesy:
 
1 - 7 of 7 Posts
Top