SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Hi Guys

Hope your machines are running great!!!

I had a 'coolant level low' indicator on for last few months even though I topped off the coolant. Took it to a mechanic and he said I had a leaking water pump. I got him to change it. When I got back into the driver seat, I noticed that my saab was not revving the same (it revs as if I have an issue with my silencer..not silencer issue but seems like over revving..not sure if am explaining this correctly). I used to love the way turbo used to kick in and the way engine used to rev. When I asked the mechanic, he said they cleaned the turbo so give it a couple of days. Turbo - instead of breathing sounds like its exhaling...overall not happy at all!! Wondering if any of you have come across this? If yes, would appreciate if you can share what the issue is. Added to this, I also have check engine light on after couple of days. I need to take it to mechanic to check whats going on but want to do some research on existing issue.

I also have had 'Stability Control Failure. Contact Saab Dealer' warning on my SID for last 3 months. It shows up whenever I start the car but there is no issue with performance of the car. Any ideas what this might be?

Since I got my car back from mechanic, I also have 'Lock system failure. Contact Saab Dealer' warning. Too many warnings..

I love the way my car drives even after 132K miles on it. I am hoping these issues will not be a big hole in my wallet.

I appreciate your response and thanks in advance.
 

·
Super Moderator
Joined
·
20,207 Posts
Cleaned the turbo?

Anyways the stability and lock failure combo leads me to believe you CIM is going out. Sorry.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
Yes, that's what he said. I thought he meant cleaned any dust around the turbo. Not sure if that's true as I have never looked at it. But why would engine rev differently (annoyingly) tas compared to before (loved it)? Any idea what would have caused it?

CIM going out. Sorry - doesn't sound right. Am I looking another 600 dollar job here after spending similar amount on waterpump?

Cleaned the turbo?

Anyways the stability and lock failure combo leads me to believe you CIM is going out. Sorry.
 

·
Registered
Joined
·
862 Posts
Yes, that's what he said. I thought he meant cleaned any dust around the turbo. Not sure if that's true as I have never looked at it. But why would engine rev differently (annoyingly) tas compared to before (loved it)? Any idea what would have caused it?

CIM going out. Sorry - doesn't sound right. Am I looking another 600 dollar job here after spending similar amount on waterpump?
Take the car to Beacon motors for diagnosis, it's a very knowledgeable Saab shop, top notch service.
Speak to Mike.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
Thanks for the recommendation. I will do that. Should have got this recommendation before I got the water pump changed but never too late!

Take the car to Beacon motors for diagnosis, it's a very knowledgeable Saab shop, top notch service.
Speak to Mike.
 

·
Registered
Joined
·
1,395 Posts
I wonder if he didn't tighten one of the boost hoses or intercooler hose after he swapped in the new waterpump? Sounds like a boost leak, or some other issue preventing it from making full boost. No CEL?

Sean
 

·
Registered
Joined
·
29 Posts
Discussion Starter #7 (Edited)
Hi Eurostyle, I will ask the question and have hom check that. If that is the case, would these leaks impact any other parts i.e. am i damaging anything in my car driving it around the way it is?

Will provide the CEL for check engine tonight once i get back home

I wonder if he didn't tighten one of the boost hoses or intercooler hose after he swapped in the new waterpump? Sounds like a boost leak, or some other issue preventing it from making full boost. No CEL?

Sean
 

·
Registered
Joined
·
29 Posts
Discussion Starter #8
Following codes showed up - p101, p300, u2143, u2142 and u 2103.

I haven't looked them yet. Posting this from my mobile. Will search on the forum once am back home.

Hi Eurostyle, I will ask the question and have hom check that. If that is the case, would these leaks impact any other parts i.e. am i damaging anything in my car driving it around the way it is?

Will provide the CEL for check engine tonight once i get back home
 

·
Registered
Joined
·
29 Posts
Discussion Starter #9
Even though I get check engine light and stability control failure issue, the car is running good.

I took it back to the mechanic, gave him ear load that engine revving was not like that and he came back saying it was the tensioner which he fixed.

I did some searching
p101 - Sounds like MAF sensor - will try steps mentioned in this thread http://www.saabcentral.com/forums/showthread.php?t=207286&highlight=p101

p300 - Plugs or Coil. I dont think its catalytic converter as car is getting power and there are no issues there

u2143, u2142 and u2103 - these seem to be related to cim. I will do some research and see if i can get around fixing these.

thanks for all your inputs so far guys.
 
1 - 9 of 9 Posts
Top