SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I own a 93 saab 9000 cs and i cant figure out whats wrong with my headlights. When the headlight switch is in the middle position (for parking lights) , the parking lights come on, but when the switch is moved to the headlight position, All lights on the car including dash lights go out. Ive read around and heard people say that this is caused by the red relay under the hood, so I got another one from a junk yard but it didnt solve the problem. Im not sure how I would go about sodering the relays if needed. This is a very annoying issue as i am going to have to travel alot at night for an upcoming job. Any advice or procedure for correcting this problem would be very much appreciated, thank you.
 

·
Registered
Joined
·
2,015 Posts
There are two relays in that box that contribute to the control of the exterior lighting system. I believe they are referred to as the "lamp control" and the "head light relay". The bigger - rectangular one- of the two is the one you replaced. The lamp control is square as looked at from the top.

I had headlight/highbeam troubles that were driving me nuts. We were finally able to isolate the problem to that particular component (mainly by taking the cover off and wiggling the PCB - high tech huh?) After that it was out with the magnifing glass and a soldering iron. Turned out it was a minute crack in the connection between the stab and the PC board.

I have a lot of time on my hands and can diagnose and repair stuff like this. But if you are uncomfortable repairing relays just go to the nearest junkyard and pick it up. Maybe ten bucks tops.

You have one of the biggest salvage yards in New England right up the street - Robertsons in Wareham. Check there.
 

·
Registered
Joined
·
2,365 Posts
Because everything on the dash also goes out, it sounds to me more likely a duff light switch than the lamp control solder joints.

However, to test a bit further, the lamp control is the left hand box, the orange one.

www.nodomainname.co.uk/Saab/relaybox.jpg

Pop this out and with the light switch on, check that you've got 12V at the centre connection.

As a path, power comes from the battery, via the ignition switch, via the light switch, which energises the headlamp relay. 12V to the bulbs themselves comes via the headlamp relay, through the dip switch and then via the lamp control unit.

If you don't have 12V at the centre connection of the lamp control unit then you've got to trace back to the dip switch, relay etc.

If you do have 12V there, then you can check it's the contacts by jumping a wire between the centre connector and either of the front and rear sockets which power left and right dip beam bulbs. If they come on in this manner then it's a solder joint.

Take apart the lamp control unit and you'll have this in your hand:-

http://www.nodomainname.co.uk/Saab/lampcontrol1.jpg

turn it over and resolder the contacts on the PCB where they meet the pins that go into the socket

http://www.nodomainname.co.uk/Saab/lampcontrol2.jpg

It's pretty painless. Basically, the unit measures the current going through the wire shunts marked S1, S2, S3, S4 and if there's a differential current, lights up the pictogram.

Problem is that the solder fractures and then the lamp control unit no longer passes current via the shunts and the bulb doesn't work and the best bit is that because it's a failure of the unit, it doesn't light the pictogram to tell you that the bulbs aren't working. Of course, technically the bulbs are working, they're just not lit!

That's why by just jumping the socket connections in the relay tray, you can hotwire the lights, you're just bypassing the duff LC unit.

I still don't think it's this which is at fault though because that wouldn't affect the rest of the bulbs, only the headlights.

David.
 

·
Registered
Joined
·
4 Posts
Similar Problem

HI,

My car has a very similar problem, I have removed both the red and orange relays and from testing and probing i think my problem (and maybe yours) is because of the ignition switch and has nothing to do with the headlights!

On my car the problem only exisits if i have fuses 29 and 30 installed for the sidelights. Looking at the wiring diagram these are powered from the headlight switch in position 1 (sidelights) and my car does not have a problem. However in the headlight position this circuit is powered off the ignition switch and the problem is present

I read tihs on a 9000 FAQ:

Ignition switch problems are common issues on Saab. What typically happens is that the electrical portion of the ignition switch fails which results in issues such as no start, no dash lights, no warning lights etc.... When you turn the ignition switch the dash lights for all the gauges should immediately turn on. If they do not then that is a good indication that your ignition switch should be replaced.
My other guess is it could be the earth connection for the rear lights because this is a known weak point. Have you fixed yours yet?
I will have another look soon and see if i can find out what mine is caused by!
 
1 - 4 of 4 Posts
Top