SaabCentral Forums banner

21 - 40 of 72 Posts

·
Registered
Joined
·
5,652 Posts
Discussion Starter #21
Do you guys also replace the rubber seals, (part #12772082) , bump stop or bellows?
Out of the 4 9-5's I have owned I have never had those parts worn out. So no I have not replaced them. If anything you can jack your car up and do a visual inspection to see what they look like.
 

·
Registered
Joined
·
2,285 Posts
Out of the 4 9-5's I have owned I have never had those parts worn out. So no I have not replaced them. If anything you can jack your car up and do a visual inspection to see what they look like.
Thanks Terry and EdT, not going to order the additional parts.
 

·
Registered
Joined
·
363 Posts
Replaced strut mounts 18 months ago with uro's ---last 6 months have been experiencing a rattle /vibration on passenger side at around 1100-2100 rpms that vibrates the left window/dash-- (seals/rollers good) --have been chasing this noise for weeks--found a couple of dodgy sub-frame bushings,changed them, all mounts checked.,replace suspect control arm bush etc...STILL there.

Last resort I took the cap off the left strut --and the nut wasn't centered !
--it was pushed across to the 11 o'clock position (viewing from side of car)--it looks like the rubber surround has failed--could this be my elusive noise ---from a dodgy mount ?
 

·
Registered
Joined
·
2,285 Posts
Replaced strut mounts 18 months ago with uro's ---last 6 months have been experiencing a rattle /vibration on passenger side at around 1100-2100 rpms that vibrates the left window/dash-- (seals/rollers good) --have been chasing this noise for weeks--found a couple of dodgy sub-frame bushings,changed them, all mounts checked.,replace suspect control arm bush etc...STILL there.

Last resort I took the cap off the left strut --and the nut wasn't centered !
--it was pushed across to the 11 o'clock position (viewing from side of car)--it looks like the rubber surround has failed--could this be my elusive noise ---from a dodgy mount ?
So are saying that the inside, rubber center surrounding the metal sleeve of the strut mount has become distorted or damaged?

That doesn't bode well for URO strut mounts. Did you purchase the black ones that came with the bolts or the silver versions that you have to self-tap?
 

·
Registered
Joined
·
363 Posts
Correct ----they're all black with set of silver screws---

-installation was fine.........but after reading this thread it prompted me to just have a quick look..........& that's what i found

--looks like one side of the thick rubber surround has just collapsed ---hopefully this has been producing my metal on metal vibration .....

i'll get another one ( different brand) this week & throw it in !!! cross everything !!!
 

·
Registered
Joined
·
363 Posts
Thanks Drew, that's very decent of you -much appreciated.

Once I get em out --some pics will be forwarded to your guys.

Quite refreshing to see a Parts rep actively seeking solutions......Nice work;ol;

Hopefully not an issue sending replacements to Oz ?
 

·
Registered
Joined
·
22 Posts
Hi Aeroclone, did some preliminary research and apparently the retailer sold you the wrong mounts for your 2003 9-5 Aero.

The black mounts (p/n 50 61 007) are only for 1999-2001 9-5 cars, so the retailer should have sold you silver mounts (p/n 52 33 366) for 2002-2009 9-5 cars.

We'll have the engineers compare the differences, perhaps that's why the black early-model mount didn't work properly in your later-model car. We've sold about 150 of the silver mounts in the last year, and only two have been returned (for unknown reasons, but they weren't noted as defective).
 

·
Registered
Joined
·
2,285 Posts
Hi Aeroclone, did some preliminary research and apparently the retailer sold you the wrong mounts for your 2003 9-5 Aero.

The black mounts (p/n 50 61 007) are only for 1999-2001 9-5 cars, so the retailer should have sold you silver mounts (p/n 52 33 366) for 2002-2009 9-5 cars.

We'll have the engineers compare the differences, perhaps that's why the black early-model mount didn't work properly in your later-model car. We've sold about 150 of the silver mounts in the last year, and only two have been returned (for unknown reasons, but they weren't noted as defective).

Hey Drew, eEuroparts shows part number 5061007A as the correct part for my 2003 Aero 9-5 2.3T Manual Here's the link: https://www.eeuroparts.com/Parts/44597/Strut-Mount-Kit-Front-5061007A/

Are you saying that these are incorrect for my 2003?
 

·
Registered
Joined
·
363 Posts
Hi Photousa---i'd reckon they're the wrong ones---i noticed that they are the exact style on my mrs 2000 9-5, & when i ordered a set for my 03, i got the same looking strut mounts you're looking at.

i confirmed with the seller that they were for an 03 --confirmed .......but i don't think so----i remembered I have the old struts from my Aero down the back of the garage -just pulled them out now & they are the SILVER type.

I've encountered this before --as SAAB is not that common now---generic parts retailers have no clue which is which for post 01 models---this is where i think I've got this strut failure. I should have gone with my first suspicion --but we live & learn...

Drew was very good in chiming in --sadly as I'm in Oz...i can't get a replacement set........Ordered locally for twice the price...bummer....
 

Attachments

·
Registered
Joined
·
2,285 Posts
Hi Photousa---i'd reckon they're the wrong ones---i noticed that they are the exact style on my mrs 2000 9-5, & when i ordered a set for my 03, i got the same looking strut mounts you're looking at.

i confirmed with the seller that they were for an 03 --confirmed .......but i don't think so----i remembered I have the old struts from my Aero down the back of the garage -just pulled them out now & they are the SILVER is type.

I've encountered this before --as SAAB is not that common now---generic parts retailers have no clue which is which for post 01 models---this is where i think I've got this strut failure. I should have gone with my first suspicion --but we live & learn...

Drew was very good in chiming in --sadly as I'm in Oz...i can't get a replacement set........Ordered locally for twice the price...bummer....
Thanks for the info Aeroclone, although I was hoping I wouldn't have to tap the three holes...
 

·
Registered
Joined
·
5,652 Posts
Discussion Starter #34
Hey Drew, eEuroparts shows part number 5061007A as the correct part for my 2003 Aero 9-5 2.3T Manual Here's the link: https://www.eeuroparts.com/Parts/44597/Strut-Mount-Kit-Front-5061007A/

Are you saying that these are incorrect for my 2003?
Those are the same ones I installed on both of 06' 9-5's and they were listed as the correct parts and I have had no issues with them. It was the ****ty silver versions that I had issues with it. The silver versions manufature quality looks like crap also. So I have a hard time believing the black version is the wrong ones.
 

·
Registered
Joined
·
2,285 Posts
Those are the same ones I installed on both of 06' 9-5's and they were listed as the correct parts and I have had no issues with them. It was the ****ty silver versions that I had issues with it. The silver versions manufature quality looks like crap also. So I have a hard time believing the black version is the wrong ones.
I did notice that the welds on the silver version look primitive : https://www.eeuroparts.com/Parts/356450/Strut-Mount-Front-5233366A/
 

·
Registered
Joined
·
22 Posts
So we consulted the latest factory Saab EPC data, and these 9-5 strut mounts are still listed as unique parts; 50 61 007 for 1999 to 2001, and 52 33 366 for 2002 to 2009. The way they mount definitely changed per Saab's own bulletin...perhaps they are dimensionally similar, but officially they're not the same part. We'll contact eEuro and ask them to correct their fitment info, unless they know something we don't.
 

·
Registered
Joined
·
2,285 Posts
So we consulted the latest factory Saab EPC data, and these 9-5 strut mounts are still listed as unique parts; 50 61 007 for 1999 to 2001, and 52 33 366 for 2002 to 2009. The way they mount definitely changed per Saab's own bulletin...perhaps they are dimensionally similar, but officially they're not the same part. We'll contact eEuro and ask them to correct their fitment info, unless they know something we don't.
Hey Drew, If I purchase a set of these: 52 33 366 will the stock 10mm bolts self tap or do I need, new, self tapping bolts or do I need to tap the bolt holes? I'm not set up with a tap to do this sort of thing, shade tree mechanic here.
 

·
Registered
Joined
·
5,652 Posts
Discussion Starter #40
Hey Drew, If I purchase a set of these: 52 33 366 will the stock 10mm bolts self tap or do I need, new, self tapping bolts or do I need to tap the bolt holes? I'm not set up with a tap to do this sort of thing, shade tree mechanic here.
You absolutely have to tap the silver version which is the ones Drew is recommending.

Personally I won't ever buy the silver versions again. The black version has worked perfect on our sedan (sold now) and now my 06 wagon. I will take my chances with them. The silver version is crudely made compared the black version. And it fits the exact the same way. The only difference between the two are the look and the untapped nuts.

I call b.s. on the part number/fitment;ol;

Hell if Drew sends me one of each I will personal measure them top to bottom and post the results here.
 
21 - 40 of 72 Posts
Top