SaabCentral Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Afternoon all-

I am unclear if I need to reset my TB as the check engine light and gear light with exclamation point (which I one I have yet to see) both lit this morning.

I have watched the videos on resetting the TB and tried myself but the one idicator the videos show is that their are 2 parts moving when the cable is moved (they say this means the TB does need reset). Mine, only one moves.

The owners manual said Limp Home mode and it does drive, but very sluggish.

Any advice on what I can do instead of taking it to a shop?

Thanks!

MJBB
 

·
Registered
Joined
·
5,000 Posts
You are in Transmission Limp Home - your transmission will start in 3rd gear, that's why it feels sluggish.

Ignore any information you read about Throttle Body Limp Home. That's not your problem.

You need to get the diagnostic codes read to find out what problem is being reported. Once the codes are read, erase the codes - your transmission limp home will go away. It might come back right away, though.

A common cause of Transmission Limp Home is a bad gear position sensor/neutral safety switch.
 

·
Registered
Joined
·
107 Posts
Disconnect the battery for 30 minutes. Then see if it goes back to normal. And for how long.

It is not in Winter mode is it? Press the W and see if it makes a difference.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
Thanks all.

In disconnecting the battery I seemed to have fixed the problem, but didn't get the codes read prior.

Just a few trips around the block, each time I turned the car off and restarted.

If it is a sensor, is this something that will need to be replaced?
 

·
Registered
Joined
·
107 Posts
Get the fluid changed. Will make a big difference. I bet it hasn't been done for ages. Do a triple flush, uses 12 litres, in 3 x 4 litre batches. Worked a treat for me.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #6 ·
Thanks for the advice. I have started the car about 7-8 times since Transmission Limp Home Mode. (Thats about 4 trips for those of you following along at home).

I get really nervous I will have the same problem as it seems to be the last light to fade out.

I had the 90K service done right after I purchased the car and all the fluids were replaced (oil, break, transmission and coolant) and that was less than 2 months ago.
 
1 - 7 of 7 Posts
Top