SaabCentral Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
Hi guys, new to the forums. So i have a '99 9-5 and the trunk switch on both the door and the alarm don't open up the trunk. I can hear it unlock but that's all. It can only be opened by the key. Any thoughts?
 

·
Registered
Joined
·
1,109 Posts
Hrm well if you actually hear the lock working to release the trunk latch I would assume either the actuator is no long attached to the latch or the trunk is poorly aligned and its binding the latch so it will not release properly does it open easily with the key or does it seem to bind at all? I would remove the panel and inspect the latch and actuator. If the actuator were not working you could inspect the harness going into the trunk since they tend to chaff.
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #3 ·
Took a look inside and you're right. The actuator clip is broken and can no longer pull the latch. The clip seems to be replaceable without replacing the entire actuator.
 

·
Registered
Joined
·
102 Posts
i had to trouble shoot a similar problem with my car the other day and found that the wires were chafed in the wire harness. i pulled the actuator from my parts car because i thought that was what was broken. if you'd like i can ship you my extra actuator for a reasonable price.
 

·
Registered
Joined
·
3,951 Posts
Hi guys, new to the forums. So i have a '99 9-5 and the trunk switch on both the door and the alarm don't open up the trunk. I can hear it unlock but that's all. It can only be opened by the key. Any thoughts?
Your in Baldwin, I'm in Freeport welcome to the forum. If you ever need help with the car I'm only one town away.
 

·
Registered
Joined
·
138 Posts
Hey Guys...I am in Queens and close to your area. It's good to see some Saab owners locally. I have the same problem with my 99 9-5 SE. The yellow clip is broken (the actuator works fine). Do you know where I can get the clip from?
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #9 ·
Yea, that's my problem. It's the yellow clip. Figured I would just get a complete actuator
 
1 - 14 of 14 Posts
Top