SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7,878 Posts
Discussion Starter · #1 ·
Hi.

I need some transmission advice.

I'm looking at either having ym transmission rebuilt or replaced, and right now I am leaning towards replacing it with a used unit from a junkyard.

My car is a 2001 Aero 5spd.

Thus far the best transmission I have found is out of a 2003, with 2k miles on it.

Will this be the same transmission as in my car? Will it fit?

Is there any difference between the 5spd transmissions in the Aero and Base models?

Thanks,
Matt
 

·
Registered
Joined
·
7,878 Posts
Discussion Starter · #3 ·
XAAMOTTOMAAX said:
I'm 99.9% sure they have used the same 5 speed in the 9-5's for every model in every model year but I will check the EPC tonight when I get home and post if there are different part numbers.

Whats wrong with your tranny? Are you grinding or having trouble getting into certain gears? Your clutch cable could be out of alignment.
Thank you very much, I appreciate it.

Unfortunately my tranny problems are much much worse.

All I can guess at this point is that the input shaft went into the flywheel, and it somehow destroyed the differential, blew out of the transmission case and spilled all the fluid out on the ground...

All this at very very light acceleration in second gear at 20mph... :(

All this on a car with 52k miles on the odometer, just out of warranty... It flabberghasts me... :(
 

·
Registered
Joined
·
7,878 Posts
Discussion Starter · #5 ·
XAAMOTTOMAAX said:
:eek: Wow thats crazy. Sorry to hear it. Everything is the same except for the drive shaft outer universal joint which changed in 2002. Did it crunch and make the wheels stop suddenly?
Hmm So could a 2003 be used in my car? Maybe I could salvage the universal joint from my current box?

I was accelerating form a stop sign, very sedatly as I was in a 25mph zone. Just shifted into second gear, as I was releasing the clutch I heard the worst scraping sound I have ever heard. The wheels didn't freeze up. I could still put it in neutral, but as soon as I tried to put it in gear the scraping noise would come back and the car would go nowhere... :(

I based my previous guess upon not knowing anything about transmission internals, but in retrospect I was probably wrong about the input shaft, as if the input shaft went, I probably would not have been able to put the engine in neutral and have it idle, no?

--Matt
 

·
Registered
Joined
·
7,878 Posts
Discussion Starter · #6 · (Edited)
I actually just had a crazy idea... :p

Since I am putting a new tranny in there anyway... I wonder if a 6spd from a 9-3ss would fit :cheesy:
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top