SaabCentral Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I’m sad… my 07 saab 9-3 Aero 2.8 automatic has been giving me a headache lately.
So first I had to replace a couple of parts since I’ve own the car for over a year now I got the car when it had about 137k now it’s has about 149k since owning the car I have replace the following
Coils, spark plugs, temperature sensor, water pump, ac compressor, thermostat housing, radiator, coolant tank, I’m sure I’m missing 1or 2 more parts. Anyhow on the recent job done with the radiator I had my mechanic change it for me about a week past and I notice my car shifting into gear was off I’ll press on the gas and the rpm will go high until it shift on to the next gear I thought it was odd never once did I had such a problem with my tranny. I did messed up my driving it the next day on the freeway and bam out of nowhere my car died on me I pulled over and let the car sit for about 5 mins turned it back on tried to shift into gear and nothing no reverse or drive. So I towed it to my mechanic the next day I went in the morning and went under the hood and notice transmission fluid on the driver side bottom where the two lines connect to the radiator it was burnt transmission oil!!! We did a transmission oil change on it thinking it was low on fluid and nothing still. We hooked up a high tech scanner that was able to function with saab it was saying that I have a bad transmission control module or neutral safety switch can this be the issue? Also I have mo check engine light on. I just recently got the stability, traction and ABS light on since we put the car on jack stands and lifted the car up pressed on the gas and made the two front tires rotate but didn’t work (after we did the transmission fluid job) I’m lost to what could me wrong don’t wanna think it’s the transmission. Any advise will be appreciated!
 
1 - 1 of 1 Posts
Top