SaabCentral Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
I've been having trouble with my stupid SID3. I had the 160000km dealer service done but I was in a rush and the mechanic forgot to clear the code with the tech2 OBD2 scanner. I tried to clear it manually but it wouldn't clear. I returned the car back to the dealer they cleared the code but it only took two started and its "TIME FOR SERVICE" again!!

Any advice??
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
Been there done that.


It's been 6 day's since the car has been to the dealer to have the code cleared and it still hasn't gone away. I've cleared it manually by holding clear until the beep and the next time I start the car it's "TIME FOR SERVICE".

Any other thoughts??
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #11 ·
I solved my problem for some reason my SID3 doesn't follow the instructions in the manual or FAQ too well.

The sequence I used for future reference...

1) Wait for message and hit clear to hide message
2) Hold clear and wait for it to say "clearing" keep holding until you hear the first beep. Here's were my is strange I can keep holding for 10 minutes and nothing will happen.
3) Release clear
4) Hold clear again and wait for hit to say "service" keep holding until you hear the second beep.

Sorry about the confussion but I was under the impression I should keep holding and wait for it to say service not release and hold again.

Hope this helps anyone with simular problems.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top