SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
Hey guys. I finally uploaded my video on YouTube and will list the link here for you. Been having issues with throttle body which makes some weird noises after i drive the car for a while and then shut it off. I also get the p0638 code every month or every other month. I already checked the H42 connector, several times, and wiring. I replaced the throttle body with another used one and it makes the same noise. Could I have just gotten another bad throttle body? Have rough idle and sluggish/surging accelration at half throttle. Sometimes accleration is fine other times it's not. Also, when cold the throttle body does not make any noise. Only after driving for a little bit.

https://youtu.be/i40ZK8ZvbJE
 

·
Registered
Joined
·
50 Posts
Hey guys. I finally uploaded my video on YouTube and will list the link here for you. Been having issues with throttle body which makes some weird noises after i drive the car for a while and then shut it off. I also get the p0638 code every month or every other month. I already checked the H42 connector, several times, and wiring. I replaced the throttle body with another used one and it makes the same noise. Could I have just gotten another bad throttle body? Have rough idle and sluggish/surging accelration at half throttle. Sometimes accleration is fine other times it's not. Also, when cold the throttle body does not make any noise. Only after driving for a little bit.

https://youtu.be/i40ZK8ZvbJE
sounds like you have another bad one. are there any other codes?
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3 (Edited)
So. The only other code i get is a p0300. But i don't get it from driving. I have to force it. Basically, the car has a rough idle so if I have the vehicle in park, and I play with the RPM up and down from 1000-1500 and just keep blipping the throttle for a minute or 2 I can trigger the p0300. I was only ever able to trigger that code once and I'm very inclined to say it's related to the throttle body because of the rough idle. The Saab shop I had it at said the ECU, wiring, and throttle body were all functioning as it should. I don't believe he hooked his tech II up to it tho. And as you can see from the video, the throttle body is not functioning as it should haha
 
1 - 3 of 3 Posts
Top