SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
I've got a 97 9000 CSE turbo that is having a brake light issue

When I turn the car on, the third brake light illuminates without the brakes being pressed. I have replaced the all of the rear bulbs on the left and right side to make sure the filaments are in good order. I have replace the brake switch to no avail. Pictogram show a blown bulb when the parking light fuses are connected. When the fuses are removed the blown bulb come on only when the brakes are pressed.
I have seen this issue come up a few time on this or other forums with the solve being a bulb issue. This does not seem to be the case.

Any input would be great.
 

·
Registered
Joined
·
283 Posts
Sounds like the diode box "filament monitor" in the back is faulty. The only way to know, for sure, is to follow the service manual and check the voltages coming in and going out of it. I have a spare unit that works. I replaced mine and it turned out being the brake switch.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
My apologies for the delay. Do you know how to check the condition of the filament monitor?

Thanks
 

·
Registered
Joined
·
283 Posts
9000 Service Manuals

You'll have to look in the electrical section for the wiring diagram for your trim level. There are some step-by-step diagnostics for the brake lights, as I found digging through for my own issues, in there but I don't recall what PDF or where it was. Please grab what you need for future reference since there is no guarantee they'll be up forever.
 

·
Registered
Joined
·
1,096 Posts
Many ! tailight /brake light issues on 9000's have been down to Bad grounds .. often with resultant meltings in the Light bulb holders in the tailights.
Pop 'em out and look closely. Then hunt down the trunk mounted Ground point.
G'luck
 
1 - 5 of 5 Posts
Top