SaabCentral Forums banner

3301 - 3320 of 3357 Posts

·
Registered
Joined
·
29 Posts
I bit the bullet and bought a second hand Tech 2 off ebay. I have at least 3 jobs to do on my car that require a Tech 2 so will pay for itself within a few uses.
 

·
Registered
Joined
·
3 Posts
rtc and clkmem failure fix

I bought one of these units 9 months ago. It seemed to work fine but over the last few months it would sometimes lose connection with the vehicles. Recently I noticed that every time I could not connect to the vehicle the rtc and clkmem would fail at the post screen. I suspected a loose connection because sometimes it would work when I wiggled the cable. I replaced the cable but it would still do it. Now it almost never worked. I noticed on the VCI module there were thin wear lines where the electrical contacts from the main board had been pressed against the pads on the VCI card. The contacts were too far to the right. I'll see if I can post a picture. I had to modify the VCI case that holds the circuit board to move the board to the right and center the electrical connections. I also found that one of the two screws that hold the VCI cartridge together would pry the board away from where I wanted it as I tightened it down. I left that screw about a quarter turn loose and tightened the other one. It now consistently passes the rtc and clkmem tests at the post screen. I will keep an eye on it and see if this has permanently fixed the problem.
 

·
Super Moderator
Joined
·
18,992 Posts
Pretty sure mine has this issue as well. It just randomly starts to fade and then resets. If I put pressure on the VCI in a certain direction it is fine. This is probably helping to align the pins.
 

·
Registered
Joined
·
3 Posts
Vci connector fix

It took me about 10 attempts before I got the VCI correctly aligned so that the Tech 2 would work reliably. Unfortunately I did not take pictures as I was fairly frustrated by that point. Since I got it working I don't want to take anything back apart.

To make the repair I took the lid off the VCI module and left the card in the bottom half of the cartridge. I had the keypad half of the device off so I could observe the pins as they slide into the main board. There are rectangular holes in the connector on the main board in line with the pins so I could see how far off my current attempt was. In the bottom half of the VCI cartridge on the right side there are 2 thin alignment shims cast into the plastic that push the printed circuit board to the left. I filed these off and slid the VCI circuit board to the right. Everything worked in the test with the lid off the VCI. When I put the lid back on I was right back where I started with the same problem on several attempts. Part of the problem is that the lid tries to crush one of the chips on the board when you attempt to reinstall it. I had to play around with the circuit board until the lid started to slid on. By that point you have no reference on where the card is in relation to your last attempt from shaking the board around. For some reason the left screw on the VCI lid would pull the printed circuit board back to the left about 1/32 of an inch during the last 1/4 turn of tightening. I had to leave that screw 1/4 turn loose and now everything seems to work. I took the VCI out and reconnected it a few times and so far the RTC and CLKMEM tests pass each time and I can connect to vehicles.
 

·
Registered
Joined
·
5 Posts
So I just did a bunch of reading of this thread (not all 150+ pages though), and I'm not seeing any links to the TIS2000 software and crack. I got my Tech2 yesterday, verified it works, but I need to pull an old desktop that I have in storage that runs XP and has a serial port. I'm not sure if the DVD that came with the setup actually has the TIS software on it or not, and probably won't find out until I get that old PC up and running. Have the links gone dead and been removed, or is there an updated link?
 

·
Super Moderator
Joined
·
18,992 Posts
So I just did a bunch of reading of this thread (not all 150+ pages though), and I'm not seeing any links to the TIS2000 software and crack. I got my Tech2 yesterday, verified it works, but I need to pull an old desktop that I have in storage that runs XP and has a serial port. I'm not sure if the DVD that came with the setup actually has the TIS software on it or not, and probably won't find out until I get that old PC up and running. Have the links gone dead and been removed, or is there an updated link?
Have you looked at all the sticky threads at the top of this forum? I promise there is one called "Tech2 Software". ;)
 

·
Super Moderator
Joined
·
18,992 Posts
I'll investigate the link later when I'm not at work. ;ol;
 

·
Registered
Joined
·
1 Posts
Hey everyone

Recently bought a clone tech 2 and seen this thread, fantastic source of info.

I have run into an issue though. I need to get a new Candi module as it wont communicate with my 2008 93SS. I've ruled out the unit itself as it communicates fine with everything on my OG 93 and does everything.

My main issue is connecting it to my 9000 using V44.000 card. It will communicate fine with some things but not others, i.e it's fine with the airbag and ABS stuff but will not talk to the engine ecu or the immobiliser

Anyone else had this issue?
 

·
Registered
Joined
·
41 Posts
Tech 2 clone connects and works on a 2002 saab just fine.

I was under the impression that the tech 2 should work with the 1998 saab 900SE. But the SAAB 148.000 card I have does not list the 900 and connecting as a generic brings up the "can't connect to DICE" message.

I am fairly certain the tech 2 does work with the 900 but what software do I need?
 

·
Registered
Joined
·
44 Posts
What if I don't need Security Access?

I have a 08 Aero Convertible. I already have several working keys. If I don't need security access would a cheap clone Tech 2 work for normal diagnosis? I have zero desire to buy an ancient laptop and fight with XP and PCMCIA cards but if it could just plug in and do the normal code reading stuff it might be valuable for me. For example, will I be able to read codes from convertible sensors? Will I be able to manually turn on the secondary air pump?

The nearest dealer is several hours away from me and is tough to get into. I'd love to do my own diagnosing if that is reasonable.

Thanks!
 

·
Registered
Joined
·
1,697 Posts
I have a 08 Aero Convertible. I already have several working keys. If I don't need security access would a cheap clone Tech 2 work for normal diagnosis? I have zero desire to buy an ancient laptop and fight with XP and PCMCIA cards but if it could just plug in and do the normal code reading stuff it might be valuable for me. For example, will I be able to read codes from convertible sensors? Will I be able to manually turn on the secondary air pump?

The nearest dealer is several hours away from me and is tough to get into. I'd love to do my own diagnosing if that is reasonable.

Thanks!

The answer is YES you dont need security access for reading and clearing DTC's and monitoring but you DO need security for programming modules,keys,changing configuration etc
 

·
Registered
Joined
·
85 Posts
Bought a clone 2 years ago, still working perfectly fine with non-candi cars.

But I can't get the tech2 to "speak" with the candi anymore. It worked for the first 2 candi needing cars, then it stopped working.

First ordered a new candi (still waiting for it), but then I read that during VCI self-test there were supposed to be 4 TPU-chips that should pass. I only got two of them passed, number 12 and 15 wouldn't pass.

I then ordered a new VCI which I'm awaiting. Gonna update if it was the candi or VCI (although I'm suspecting VCI since candi lights up and clicks when the loopback-adapter is connected on the end of the line like it should).
 
3301 - 3320 of 3357 Posts
Top