SaabCentral Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi All!

Three days straight, a couple of 5am finishes and little progress to show for it. To say I'm frustrated is an understatement!!

My (clone) Tech2 does everything (read/clear codes, makes adjustments on all modules, etc) but allow me to program anything. I have full access and rights through both TIS2000 and GlobalTIS via an older Dell-Windows XP (fresh install) laptop with straight RS232 connection. I have tried everything recommended, including, but not limited to:
  • Re-flashing the Tech2, trying different software revisions along the way
  • Re-flashing the card, trying different software revisions along the way
  • Changing the slot the card is in
  • Remote, Pass-thru, etc operation via the Tech 2 and through both TIS2000 and GlobalTIS
  • Changing COM ports, although I needn't (a sign of just how desperate I've become)
  • Removing the battery (GM recommendation) to drain all power from the car and reset
  • Then, trying it on a different (9400) car
The list really does go on, but I won't bore you with it.

What I haven't tried:
  • Performing the operation on a (9440) with the Candi (just to see if that makes any difference)
  • A different OBD lead; as I only have the one that came with the unit
  • Putting the Tech 2 in the freezer for a few hours
These are the two error messages I receive when simply attempting to read the VIN/ECU information so as to then gain security access:
273680
273681


I keep thinking I've missed something simple, but have been over it so many times I'm at a loss!

Any ideas would be greatly appreciated!!
 

·
Registered
Joined
·
8,652 Posts
What car and module are you trying to program?

The V44 software will let you do OG9-3 and 9-5 up to at least 2003. Of course there are only a few modules that can be SPSed in the 9-5: ECU, TCU, ACC.
 

·
Registered
Joined
·
7,460 Posts
V44.000 do not let you do any 9-3 or 9-5.
44.000 in for 900 and 9000 ONLY.

You have bad cable or wrong port selected in PC.
 

·
Registered
Joined
·
8,652 Posts
V44.000 do not let you do any 9-3 or 9-5.
44.000 in for 900 and 9000 ONLY.

You have bad cable or wrong port selected in PC.
Mimmi, that is incorrect. I have done SPS on my 2003 9-5 using V44. This was only ACC, I have not tried ECU.

See Technical Bulletin 02-11-248.

273690
 

·
Registered
Joined
·
8,652 Posts
....And I used V44 after having no luck with V148. Apparently there is a version of V148 that does allow SPS programming. We have a club member who does have that card, but due to lockdown we haven't had a chance to investigate/update.

Confusingly, both versions of software are 148.00. Not sure how to tell them apart, or whether there is a bad copy out there.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Hi Mimmi, EdT,

Thanks for your replies.

The car is a 2000 9-3 and I will be looking to program a spare ECU for it. I will also need to program spare keys for other 9-3 (9440) models for family.

When you say a bad cable, do you mean the network cable or the OBD cable? As I have swapped several network cables in-out with no difference. The OBD cable I too can't be 100% sure, as I only have the one. However, for all other functions, it has worked perfectly.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Thanks again EdT,

I take it from that, that I'll need this V44.

I can't believe that after the hours of reading over the last few days, that this is the first I have heard of it.
 

·
Registered
Joined
·
8,652 Posts
Hopefully it works properly for you!

It's been a year since I tried to do SPS, so I forget what errors I was getting with the 148 card.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Thanks EDT.
44 didn’t work (same error) so I’m working my way back through them in case I missed one. That said, I can’t see why I’d have to jump between revisions based on the model I’m working on. No-one’s mentioned it (that I’ve read) and it doesn’t make sense that GM would update the software without a degree of backward compatibility.
The fact I can communicate with all the cars I’ve worked on but not pull a VIN to the Tech2 doesn’t make sense to me.

I’ll try the next one in the morning, but I feel I’m just repeating what I’ve already tried.

Thanks again!
 

·
Registered
Joined
·
7,460 Posts
V44.000 do not work. V44.000 do not even have 9-3 or 9-5 to select.
You need to use 148.000.
You have bad cable between TECH2 and PC or incorrect port selected.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12
Hi Mimmi,
Thanks for that.

So, I worked my way back through to 148.000 again. I have also completed another round of the Tech2 self tests, which passed. I then took out and apart the VCI and (with a multimeter) checked all the connections from the PCB to every pin along the connection path through to the end adapter, which were all good also.

Again, what I don't understand is being able to program those modules in a 1999 (9400) 9-3 that don't require security access, but when I request the VIN to potentially program a new ECU, it fails.
 

·
Registered
Joined
·
7,460 Posts
If you program modules, you do not need to use serial port.
If you request VIN to program new ECU, you need serial port to PC.
So, I say that you have either bad serial cable, bad/invalid serial/usb dongle or wrong port selected in PC.
TECH2 is extremely sensitive to serial/usb dongle
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14
Thanks again Mimmi.

I understand, however, I think there is some confusion as to which step in the process my Tech 2 is failing, as it is unrelated to the Tech2-to-Compter/Laptop connection.

I don't have that computer in front of me at the moment to screenshot the steps, but will post again over the weekend.

I appreciate your help.
 

·
Registered
Joined
·
8,652 Posts
So:

  • I was incorrect, it was V43.000 that I was referencing
  • The problem I encounter with V148 is that the Tech II locks up immediately when selecting SPS programming; the unit has to be turned off and on to restart it
  • V43.00 does indeed do SPS programming of 2003 9-5 (see pictures below)
  • V43.000 has only selection for Saab 9-3 and Saab 9-5 from 1998 to 2002 if SPS programming option is selected (so no luck for NG900 owners)
  • For 2003 9-5, select 2002 and continue, no problem
  • V43.000 does not work with NG9-3, probably does not recognize CANdi
  • I did not follow through on the SPS, but believe me, it works, I SPSed the ACC, and when I get around to checking the spare ECU I have, I will SPS that
273769
273770
273771
P1320919.JPG P1320920.JPG P1320921.JPG
 

·
Registered
Joined
·
468 Posts
Try using v.146 on the Tech2 (get it from GlobalTIS). I ran into similar problems doing an SPS ECU reflash on a 9-3SS with v.148. I posted about it a few weeks.ago.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #17
Okay, so a bit of a delay in getting back to this with my work kicking back in.

Big thanks EdT for taking the time to verify that for me. It was a massive help to be able to tick that one off the list!

Basically, I think I've worked it out having clarified a couple of unknowns that still existed despite all my testing to date.
  1. I packed up the Tech2 and waited till I had access to a 9440 9-3 that I've been working on. Plugged it in, read and loaded the VIN, no problem. That had me confident it wasn't a hardware issue.
  2. I, like a few others, didn't have the security access icon on the TIS2000 desktop showing. However, I had it on my GlobalTIS desktop and could access that. So, I re-installed TIS2000 and voila, there it was. Don't ask me why; I followed the same walk-thru as before, I simply got a different outcome. After the amount of time I'd spent on this, I simply took it and moved on.
I have since completed programming on the 9440 9-3 and as soon as I have the time available, I will roll back to v.146 and fingers-crossed, everything will work similarly on the 9400 and that'll be the end of it.

I don't think I wanted to know that much about the Tech2 hardware (dismantling and testing VCI modules, pin-outs etc) but knowledge is power, right??

Thank you all again for your help!! 👍
 
1 - 17 of 17 Posts
Top