SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,081 Posts
Discussion Starter #1
Hi guys,

Owner of a 2006 9-5 here.

I know that Saab changed the length of the "inducer nose" on the TD-04 turbocharger starting in 2006, to accommodate the king cobra pipe.

It seems that this turbo is compatible with older cars (pre-2006). My assumption is that you'd have to also update to the king cobra pipe to make it work with a pre-2006 car.

So my question is: Is there any way a TD-04 from an older car, say MY 2004, could work in the 2006+ cars? I'm thinking a turbo replacement might be in the works down the road (mine does a faint "police siren" noise** at low RPM), and I have a buddy who has a completely rebuilt TD-04 that he'd be willing to sell me. But I think it came out of a pre-2006 car, so I'm not sure that it will work. Thoughts?

**Note: I will say, my car has been doing this noise for quite a while now (only at low RPM). At least 15,000 miles. The Internet says that the "police siren" noise is a sign of impending turbo failure, although some forum threads I've read say their car has been doing it forever without drive-ability issues. I'll keep an eye on it. Just trying to plan for the worst. Maybe nothing will happen.
 

·
Registered
Joined
·
7,414 Posts
I see two options: (I'd probably opt for the first)

  • take the turbo apart and use the king-cobra compatible compressor housing with the older turbo. I'm pretty sure that there was nothing different on the CHRA for the TD-04 so it should bolt right up
  • Find an older style Cobra pipe that will match up with the older turbo to "downgrade" your car. Not sure the difference will matter unless you have a heavy tune in the car.
 

·
Registered
Joined
·
2,081 Posts
Discussion Starter #5
my understanding is that the only difference is the inlet. the compressor wheel and exhaust housing are the same
Any comments or insight on the "police siren" noise at low RPM? I get conflicting advice from the Web. Some say impending doom, others say their cars have been doing it forever without ill effects.

The car drives fine and boosts partway into the red as it should. Feels as zippy as ever. So am I making an issue out of nothing?
 
1 - 5 of 5 Posts
Top