SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello first post so sorry if this is in the wrong section. I have a 2004 saab 9-3 I bought not to long ago it has 242xxx miles on it. We replaced the radiator about 2 weeks ago, and sense then the tcs symbol with a line through it has been on, and the nightpanal, customize, esp, clear buttons are not working either. My father did spill some tea in the car at the same time we did the radiator and it did sit over night and while he was at work during the day, because he forgot about it. I have searched every where I think and can't find anything that sounds the same. We pulled the radiator from the top and not out the bottom.
 

·
Super Moderator
Joined
·
20,206 Posts
Time to find yourself a tech2.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Time to find yourself a tech2.
Do you think it's major? The car drives fine so I will probably just drive it (paid $400 for it) any suggestions on what to do don't want to take it to someone and be charged a small fortune.
 

·
Super Moderator
Joined
·
20,206 Posts
Never can say what is wrong with it. The tech2 scan will tell you. If you are anywhere near Knoxville or Nashville one of these 2 might be able to scan it for you and they are at least half of what a mechanic would charge.

http://www.saabcentral.com/forums/showthread.php?t=383074

Where was the tea spilled?
 

·
Super Moderator
Joined
·
20,206 Posts
Check battery voltage.
 
1 - 7 of 7 Posts
Top