SaabCentral Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
377 Posts
Discussion Starter #1
I installed a used ecu in my 2002 9-5 aero MT, the ecu came from a 2002 9-5 aero AT
I got the immobilizer synced and the car starts and drives, but I have abs and esp warning lights and also the (P) icon on the dash. Is there a process to add my vin to the ecu so it will function or am I missing something else?
Thanks
 

·
Registered
Joined
·
377 Posts
Discussion Starter #3
Mimmi, I have the tech 2. I just can not find the menu to do so
 

·
Registered
Joined
·
377 Posts
Discussion Starter #6
I have gone in to dive and I can select sport chassis with 16" brakes, but I am unable to select engine size. I have options to choose from but I select the correct variant and it does not apply. Vin does match my car.
 

·
Registered
Joined
·
377 Posts
Discussion Starter #11
Unfortunately mimmi, I have not because I have abs faults and cannot get them to go away. Fault code C0551 is showing still
 

·
Registered
Joined
·
377 Posts
Discussion Starter #15
Mimmi I do appreciate your effort to help, but I dont think that is the case. I never once had a abs or TCS problem and both functions worked when needed, problem only came when i took out the tuned ECU and reinstalled the stock ecu and tried to program it
 

·
Registered
Joined
·
8,652 Posts
Can you go back to the tuned ECU you removed? See if the problem persists or goes away.

Can you read any data from the ESP module?

My 2003 Linear has a possibly flaky ESP module. It seems to work okay (maybe a bit too sensitive on bumps). However there are intermittent difficulties with Tech II communicating, I cannot choose 16" brakes and standard chassis option (in fact I can't choose 16" brakes and sport chassis either, only 15" brakes and sport chassis if I so desire).

When I try to see the software version, Tech II gives me ////////

I get the feeling that the earliest ESP modules were not that wonderful. Good luck finding one in the junkyard, they're always pulled.
 

·
Registered
Joined
·
377 Posts
Discussion Starter #19
EdT, I did swap the tuned ecu back in and the same problem. I feel as tho I am not programming the abs module correctly. I am unable to select the correct engine size and transmission combo, with either the tuned ecu that I have had installed in the car for 4 years, or the original that I just reinstalled. Never one warning light prior to doing the swap and the lights came on immediately at start up. I didnt even back the car out of the garage
 
1 - 19 of 19 Posts
Top