SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
My power sunroof was slowly dying and this morning it finally quit. I haven't had too much time to check into it (I took apart the switch and the contacts look good) but I'm assuming it's the motor. I was at a junk yard last year and saw a couple manual sunroofs, I was wondering if a manual one would fit in my car or should I just opt for a new motor?
 

·
Registered
Joined
·
9,170 Posts
New sunroof motors are $$$. You might get a junkyard one cheaply. Normally it is the grub screws that come out iof the motor that fail - these are 8mm. Replacing them with larger ones might solve it. Also check that the cables going into the motor are attached correctly. Does it sound like it is working but doesn't move, or is it totally dead?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
it used to work, but you had to help it along, now I don't even get that buzzing sounds anymore. I'm going to check and see if there is voltage at the motor in a min.
 

·
Registered
Joined
·
3,286 Posts
Things outside the obvious to look for:

1. Good ground. A bad ground could make the motor run slower and slower then quit. If you have low voltage at the motor that's something to check.

2. Cable impediment - if the cable won't move, the sunroof won't either! Work the cable a little to see if it is freely moving.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
you were right about the screw, I went to close it up manually (it happened to die as I was opening it) and found that whole piece to have fallen out. Screwed it back in and the sunroof is back to it's good ol' self. It still gets stuck in two places, but that's no big deal at the moment.

Thanks
 

·
Registered
Joined
·
204 Posts
Not the sunroof too!!!

I have a serious problem. I have no air con, my windows don't go down because I need to rebuild the motor assemblies, it is summer and now my sunroof has started acting funny.

I did a search of the forum and came up with two possiblities. The symtoms are as follows;

When opening, on reaching fully open, instead of the clunk noise when the roof stops there is now a load of clicking. When closing the roof it gets stuck and makes the same clicking. Give it a little shove and it moves another few inches and stops again.

This sounds very similar to cincyftc's problem. Whats the deal with the screws? I also found alot of posts about the plastic drive gear in the motor losing its teeth, which would be consistant with the sound. Do I just open the motor and there it is? What Jags is it which have the right part?

Any pointers to speed the fix would be greatly appreciated so that I don't melt over trhe next few days. Jezz, you seem to be our sunroof guru.
 
1 - 6 of 6 Posts
Top