SaabCentral Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
I recently got to the finishing stages of my 94 C900 vert project and decided to fix the A/C, it was discharged so i pulled a vacuum on it for 20 mins then recharged with freeze 12. All worked great, really cold. Well today i went out in it in the heat to test it, 92F, it works good while driving but not really well when in traffic, that could be to do with no air passing through the condenser, and also the compressor not spinning very fast. But my strange issue is when i parked the car at the store and turned the key off, i noticed the blower in the dash still blowing, the twin electric fans on the radiator still blowing, and the battery and oil pressure lights were illuminated. I fiddled with the ignition thinking this could be stuck but it wasnt as my radio went off. I then pressed the A/C 'snowflake' button on the dash and everything shutoff. I pressed it back on and nothing came on. This happened again when i got home!! Pressing the button turns it off. Any ideas?? Is this supposed to do this??
 

·
Registered
Joined
·
2,537 Posts
.......possible sticky, lazy (whatever description) 40 Amp Ignition relay.....?Or sticky, dirty or lazy ignition switch.........?
 

·
Registered
Joined
·
1,534 Posts
Bad grounds can produce the craziest most illogical symptoms. Check the grounding points. There's one on the frame near the radiator drain and one near the AIC on the intake manifold. Clean them well. It seems like there's a couple under the dash too for which I can't remember the locations.
 
1 - 4 of 4 Posts
Top