SaabCentral Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Video of issue.
I thought replacing the alternator would help here, but it hasn't. CEL is p0245 not sure if this is related or not. I can keep the engine running if i give it gas and hold it for a minute or so. Then it idles "ok". Driving it though is another story. Engine cuts out when you accelerate under load and it dies out.


My next step is going to be replacing plugs and injectors. Is there anything else you all would check/replace while i'm trying to diagnose this issue?

xwd error is next on the docket. Car running smoothly is up first.

Thank you
 

·
Registered
Joined
·
91 Posts
What engine? Definitely need to scan with a tech2 but if you don't have one I would initially check the fuel pressure. There should be a fitting on the fuel rail that you can hook up a traditional fuel pressure tester to. I don't remember the exact pressure you're looking for (can check here SAAB Workshop Information System Online – SAAB WIS Online) but you may see a sudden drop in pressure then the car cuts out. That would likely lead to a faulty pump. Always good to replace plugs and go with new coils if you're having any cutout issues. Go with OEM's, don't cheap out on coils!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
What engine? Definitely need to scan with a tech2 but if you don't have one I would initially check the fuel pressure. There should be a fitting on the fuel rail that you can hook up a traditional fuel pressure tester to. I don't remember the exact pressure you're looking for (can check here SAAB Workshop Information System Online – SAAB WIS Online) but you may see a sudden drop in pressure then the car cuts out. That would likely lead to a faulty pump. Always good to replace plugs and go with new coils if you're having any cutout issues. Go with OEM's, don't cheap out on coils!
The 2.8l v6. Okay I'll add that to the list. I'm not sure why I didn't think it'd be fuel-related? Probably because there's so much electrical issues going on. But thank you, I really appreciate it
 

·
Super Moderator
Joined
·
2,969 Posts
P0245 is charge air control valve, open or short to ground. This is usually an electrical fault, and while I've never seen this fault on ME9 before I'll give you some possibilities.
Pink / Black wire to the "charge air solenoid valve" is shared with:
Front Oxygen Sensor
FRONT CYLINDER BANK INTAKE CAMSHAFT SOLENOID VALVE
REAR CYLINDER BANK INTAKE CAMSHAFT SOLENOID VALVE
BY-PASS TURBO SOLENOID VALVE
EVAP CANISTER PURGE VALVE ON REAR CYLINDER BANK

This all receives power from the Engine Control System Relay. When it closes it also supplies power to the coils, and because the car runs I don't think it is a relay issue. Possibly one of the above components are drawing enough current to pull power from the boost solenoid (unlikely) and one of the above components have failed. Purge valve are very common. Looks like a tough one man, good luck. Personally I would either bypass or replace these components (my situation is different because I have parts / donor vehicles).
Tom
 

·
Registered
Joined
·
2,800 Posts
Man, scan it first before u dump any money .. having the xwd msg and the traction/abs fault could indicate communication issue that would cause the engine to behave weird
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Man, scan it first before u dump any money .. having the xwd msg and the traction/abs fault could indicate communication issue that would cause the engine to behave weird
Yea i'm going to bring it to a saab shop and have them scan it. A lot of issues that i dont know, and I dont want to throw a bunch of money at. Thank you
 

·
Registered
Joined
·
2 Posts
Video of issue.
I thought replacing the alternator would help here, but it hasn't. CEL is p0245 not sure if this is related or not. I can keep the engine running if i give it gas and hold it for a minute or so. Then it idles "ok". Driving it though is another story. Engine cuts out when you accelerate under load and it dies out.


My next step is going to be replacing plugs and injectors. Is there anything else you all would check/replace while i'm trying to diagnose this issue?

xwd error is next on the docket. Car running smoothly is up first.

Thank you
Hi my Saab 9.3 was doing the same thing and was told it was the CPU but it wasn't, alI had to don was to replace the CPS, since then had no problem and only spent $146.
 

·
Registered
Joined
·
1,216 Posts
Hi my Saab 9.3 was doing the same thing and was told it was the CPU but it wasn't, alI had to don was to replace the CPS, since then had no problem and only spent $146.
Do you have V6 engine?
 
1 - 10 of 10 Posts
Top