SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I'm having problems with my 1991 Saab 9000 Turbo. For a while when driving it would randomly shut off all the electronics (radio, gauges, HVAC, ect) and then they would start back after a second or two. Then it would totally shut off while driving and would usually start back up, but then it wouldn't start. I rolled it down a hill and bump started it, but then it died at the stop sign. I bump started it again and then drove it home, about 10 miles and it was fine. Now it is stuck in my driveway and won't start. When I turn the key the starter doesn't click or anything.... the electronics turn off but the starter does not do any clicking or anything. Hope someone can help!!

Thanks!!
 

·
Registered
Joined
·
285 Posts
I'd start with a new ignition switch... Just the electrical part.
 

·
Registered
Joined
·
2,026 Posts
What does your system voltage read as indicated on the dash?

With the engine running, hit the info button enough times to get back to voltage reading. Should be at least 13.0. That's minimum, 13.5+ is better.

If it's lower than 13 volts the problem may be that ECU has gone into "emergency mode".

You've probably already checked this, but if not - try a new battery. If the battery is known to be good, be sure the alternator is charging the system.

What happens is; When total system voltage reaches some pre-determined critical point (i.e. it drops to the point where engine function would be affected), the ECU will begin to selectively shut down non-vital accesories.

First things to get cut-off are radio, climate control, dash lighting, etc...

If you don't have a spare battery in good condition (and has the posts in the proper positions), you can test it by hooking up jumper cables from another vehicle, or a heavy-duty battery charger.

If your auxiliary systems start working while receiving power from an outside source, you need to look at your battery/alternator.
 

·
Registered
Joined
·
3,938 Posts
A relatively common problem is corrosion between the battery posts and the inside of the battery cable terminals. This can give symptoms of a bad battery when the battery is in fact good.

Cleaning the terminals is easy to remember, cleaning the insides of the cable terminals gets forgotten. Also, sealing the connections once cleaned and reconnected should be done. I use a dab of Vaseline(white petroleum jelly) if the spray sealer is not readily available. Engine compartment heat melts the Vaseline and seals out the damp air which causes the corrosion in the first place.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
I haven't driven it in a while but I think the battery voltage was reading around 11-12 volts.....after I cleaned my battery terminals and the body grounds behind the battery it was around 13 or so but then it went back down to the 11-12 range. Should I start off with the ignition switch?
I have to get a scanner to clear the "emergency code" if that is the problem, correct?
 

·
Registered
Joined
·
21,583 Posts
What does your system voltage read as indicated on the dash?

With the engine running, hit the info button enough times to get back to voltage reading. Should be at least 13.0. That's minimum, 13.5+ is better.

If it's lower than 13 volts the problem may be that ECU has gone into "emergency mode".

You've probably already checked this, but if not - try a new battery. If the battery is known to be good, be sure the alternator is charging the system.

What happens is; When total system voltage reaches some pre-determined critical point (i.e. it drops to the point where engine function would be affected), the ECU will begin to selectively shut down non-vital accesories.

First things to get cut-off are radio, climate control, dash lighting, etc...

If you don't have a spare battery in good condition (and has the posts in the proper positions), you can test it by hooking up jumper cables from another vehicle, or a heavy-duty battery charger.

If your auxiliary systems start working while receiving power from an outside source, you need to look at your battery/alternator.
Fully agree..EXCELLENT advice..;ol;.do this service and if all checks out OK, then go to the switch.........
9000s have a built in voltmeter ???
Even a '96 CS ??
 
1 - 6 of 6 Posts
Top