SaabCentral Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
hi guys

i have a saab 9-5 2.3 Turbo ecopower

i fitted an induction kit too it and it kept on stalling and the noise was awful so i took it off,

since removing it and fitting the standard airbox on it seems to stall if i accerlate hard in first them push in the clutch and let the revs die down. its doesnt do it all the time but its annoyingly frequent.

does anyone know what may cause this and what i can alter to combat this, also the idle seems to fluctuate when i use more electric stuff
 

·
Registered
Joined
·
22,211 Posts
Stalling.............previous causes have been:

vacuum pipes
crankshaft position sensor
throttle body
fuel filter
fuel pump
others guys.....................?

I think you need an indie or dealer now you have checked the obvious, could you have damamged the air mass sensor in the filter install? :confused:
 

·
Registered
Joined
·
22,211 Posts


Sensor shown here :confused:
 

·
Registered
Joined
·
90 Posts
Discussion Starter #4
but if it was the MAF would it not run badly all the time on idle ??? wether i accerlate hard or not??

its very strange as the car idles FINE, until i boot it in first push in the clutch and let the revs go back to idle,

normal driving is perfect and fuel consumption is good, engine runs smooth throughout the rev range too

im not sure if anyone else has had this problem

the MAF hasnt been though since fitting the filter as i fitted it onto the end of the standard intake pipe so i dont see why it should have got hit or bashed about

your help is much appreciated guys :)
 

·
Registered
Joined
·
5,641 Posts
If everything is fine til you give it the boot I'd check for a boost leak.
 

·
Registered
Joined
·
1,442 Posts
I had i loud "Farting sound" from mine now n then, turned out to be the dump valve diaphram had split.
 

·
Registered
Joined
·
22,211 Posts
Martin_9-5t said:
I had i loud "Farting sound" from mine now n then, turned out to be the dump valve diaphram had split.
Ye olde hooter valve ;)

I used to get this really annoying whining sound just nagging away at me in the car........

It stopped when she got out at the shops though :cheesy:
 

·
Registered
Joined
·
5,641 Posts
Martin_9-5t said:
I had i loud "Farting sound" from mine now n then, turned out to be the dump valve diaphram had split.
That's a good way to describe the noise I'm getting. :p I have no trouble holding vacum or boost and it bypasses just fine with a loud psssst, but every once in a while when the turbo needle is at 0 (neither vaccum or boost) I get a loud, resonating fart noise. I don't think this is Jim's problem as it's a recirculating system, unless it's cracked and venting to the atomsphere.
 

·
Registered
Joined
·
22,211 Posts
The bosch valves are quite prone to this problem :confused:
 

·
Registered
Joined
·
90 Posts
Discussion Starter #10
Chris 9-5 said:
The bosch valves are quite prone to this problem :confused:
where would i be looking to solve this problem do you think

i know the pipe coming from the top of the standard BOV is quite perished, would that cause it?? it seems a bit of a job to change though
 

·
Registered
Joined
·
22,211 Posts
Those small bore vacuum pipes do decay and split, so change them for silicon ones!

The valve itself isnt expensive, an upgraded alloy one is dearer but is serviceable so lasts forever!

Silicon pipe I got from www.partsforsaabs.com

http://www.partsforsaabs.com/product_info.php?products_id=1130

To remove the old pipework, be careful not to snap the connections by pulling the pipework too violently, use a knife to cut the end away first!

 

·
Registered
Joined
·
90 Posts
Discussion Starter #12
i have checked the pipe and its perished to buggery, so i will change it tommorow fingers crossed :)

cheers guys :)
 

·
Registered
Joined
·
90 Posts
Discussion Starter #13
well at last i cured the problem , it was a very badly perished vaccum pipe on the BOV changed it and it completely smoothed out the running of the car,

also found aq cure for the strange intake noise, the filter was too big, tried a smaller one and its fine

thumbs up all round :D
 

·
Registered
Joined
·
22,211 Posts
Well done Jim ;)
 
1 - 14 of 14 Posts
Top