SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
399 Posts
Discussion Starter #1
So long story short, I had to rebuild my engine after my head gasket failed and leaked coolant in cylinder #3. Everything is now perfect except for an annoying squeak / chirp coming from below the shifter (I think). Possibly originates from somewhere down below near the firewall or rear part of engine? Happens over uneven pavement, or on anything above light acceleration and just before coming to a stop. Seems to be fore-aft movement of something rather than side-to-side. No noise when coasting on smooth roads or on sharp turns. Also happens right on engine start-up for a brief second, and sometimes when shifting into R or D. Don't feel any vibration or anything through the steering wheel. Checked exhaust (all tightened up), rear and left side engine mounts and all look good. Lower transmission mount (torque rod) is polyurethane and was replaced a couple of years ago so I doubt that's the issue either. I'm out of ideas, perhaps someone can point me in the right direction. Here's a link to the sound on light/moderate acceleration. Thanks in advance for any help!

 

·
Registered
Joined
·
7,460 Posts
Sounds that tex phone antenna cable connector hits dash frame. Phone cable is behind storage tray.
 

·
Registered
Joined
·
399 Posts
Discussion Starter #3 (Edited)
EDIT: For posterity's sake (don't you hate threads that don't find a solution?), the problem was traced to a loose joint at the front of the flex pipe.
 
1 - 3 of 3 Posts
Top