SaabCentral Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
328 Posts
Discussion Starter #1 (Edited)
Speed Sensor Question & a few pics

Hi guys, I just installed a Kenwood double Din 6.5 Monitor in my dash and a Nav system in my trunk. Cool unit. My question is.
My Nav needs me to connect a wire to my speed sensor. Most of the search results I see say that the car gets it's speed info from the rear left wheel, but I also see posts where is says that the car gets it's speed info from the front wheel.
which one is it?
The only thing I see behind my wheels are abs sensors?. Am I to splice the wire from my Nav into that wire(abs=speed senor)?? Which wire...since there are two attached to the sensor.
Sorry for the confusing post.

maallen40
 

·
Registered
Joined
·
9,874 Posts
Another change to your stereo system?


I just had the emmission test done on my car and I can safely say that the speed sensor is only in the back!
It was quite the experience watching my car running up to 2400 rpm ... and the speedo didn't move!:eek:
 

·
Registered
Joined
·
29 Posts
i installed a gps nav head unit, and took the speed sensor wire from the abs control unit connector, using one of those blue scotch block connectors, and taking the wire through the bulkhead to behind the dash then up to the head unit. this worked fine.

i believe there is a speed sensor on each wheel, and they all feed into the abs unit, but to get the signal you need for the nav, it is the one from the abs unit to the speedometer you require.

it is the orange/white wire which i got to by cutting away at the sheath on the wire/ connector going into the abs unit (the one with green tubes going into it in the engine compartment)
dave
 

·
Registered
Joined
·
328 Posts
Discussion Starter #4
Thanks Dave....found it right away and yep.....it works.
Thanks again.

jetuk said:
i installed a gps nav head unit, and took the speed sensor wire from the abs control unit connector, using one of those blue scotch block connectors, and taking the wire through the bulkhead to behind the dash then up to the head unit. this worked fine.

i believe there is a speed sensor on each wheel, and they all feed into the abs unit, but to get the signal you need for the nav, it is the one from the abs unit to the speedometer you require.

it is the orange/white wire which i got to by cutting away at the sheath on the wire/ connector going into the abs unit (the one with green tubes going into it in the engine compartment)
dave
 

·
Registered
Joined
·
328 Posts
Discussion Starter #5
Yep....and this one is awesome.....Its the Kenwood Double Din DX7015 6x5" monitor dvd/mp3 player, and I put the optional nav unit DV4100 in the trunk.

Remember that monitor I had just over the gove box for my old DVD player? Well this afternoon I'll stick it behind one of my headrests.

Ofcourse I now have to find something to do with my old DVD/Mp3 player.

Thanks scott....and later.

maallen40



SaabScott said:
Another change to your stereo system?


I just had the emmission test done on my car and I can safely say that the speed sensor is only in the back!
It was quite the experience watching my car running up to 2400 rpm ... and the speedo didn't move!:eek:
 

·
Registered
Joined
·
9,416 Posts
What kind of modifications did you have to do to the dash to fit a double-DIN head unit? It's always looked like the hole was about 1/4" to 1/2" too small.
 

·
Registered
Joined
·
328 Posts
Discussion Starter #7
None what so ever....its a clean fit, you just can't use the faceplate that comes with it because the head unit sits out about a quarter of an inch. I could sand down the face plate for a flusher fit, but hey.......a quarter of an inch I cam live with.
I'll post a pic shortly.


Jeremy R. said:
What kind of modifications did you have to do to the dash to fit a double-DIN head unit? It's always looked like the hole was about 1/4" to 1/2" too small.
 

·
Registered
Joined
·
3,009 Posts
Very nice set-up. I assume you've checked out stuart_mc's post on the in-car pc? You guys are way beyong me on that sorta technical ish.
 

·
Registered
Joined
·
591 Posts
I'm a bit confused now!:roll: Is the HU size from Ng900 and 9-3 same? Looking at those pictures it looks like the SID is a bit higher, for instance, 900 doesn't have that plastic insert between SID and HU, am I right?
I should realy pull my sleeves up and start installing that 2-DIN Sony I bought, truth is I havent checked out everything, maybe I don't even need to change the cage of the unit. I remember that Kenwood excellion had dimensions 178X100X155mm which is the same as on my Sony, but comparing to 9-3 unit it lacks 4mm in middle number, yet it fits perfectly in NG900.
Any smart word? Has anyone else installed double-DIN aftermarket unit in his car?
 

·
Registered
Joined
·
328 Posts
Discussion Starter #11
Go for it. For years I Bit*hed about wanting to change my radio, because the truth is...Saab radios are garbage. In the last 12 months I have gone through 3 different head units... and finally I think I have found one I am happy with, and for 3 grand plus........I hope so.

Pull out that stock 9'3 radio and try your double din radio...It should fit.
Mine sticks out less than a quarter inch, but it's flush and square and to me....looks just fine. I just could use the surrounding faceplate that came with the radio, but no big deal.....it looks fine.

Let me know if you try it.



Marquis de Saab said:
I'm a bit confused now!:roll: Is the HU size from Ng900 and 9-3 same? Looking at those pictures it looks like the SID is a bit higher, for instance, 900 doesn't have that plastic insert between SID and HU, am I right?
I should realy pull my sleeves up and start installing that 2-DIN Sony I bought, truth is I havent checked out everything, maybe I don't even need to change the cage of the unit. I remember that Kenwood excellion had dimensions 178X100X155mm which is the same as on my Sony, but comparing to 9-3 unit it lacks 4mm in middle number, yet it fits perfectly in NG900.
Any smart word? Has anyone else installed double-DIN aftermarket unit in his car?
 

·
Registered
Joined
·
591 Posts
I got mine from eBay and it came from Japan almost 2 months ago. Not as nice as yours, but it has both CD and MD and works perfectly as far as I tested it on the table. I've been watching it since then. :( Next weekend, I promise, his ***** is mine. Temperature is rising, windows are down almost all the time... it's time to finish that spring project and release the sound!!!
 
1 - 12 of 12 Posts
Top