SaabCentral Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
Ok. So I have a sweet little 2006 9-3 Aero. It's got that bangin 14 speaker stereo. Anyway, I lost all sound, no chimes, nothing. Blank screen on the ICM3 display. Had no fiber optic signal, yet I changed out AMP1 cause it was rustier than an old Chevy. Checked all my fuses. All are good. Checked to see if the ICM3 Head unit had stopped working by trying another ICM. Still no joy. My only guess is the CD changer part has given up the ghost. Anyone else had this issue?

Also, side note. The left track of my driver seat will not move, just the right. How do I fix that?
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #2 ·
Added bonus. Pulled everything out. ICM3, EHU, 6 disc CD changer. What's got me worried is I'm not seeing any red light. Maybe I cocked up by unplugging both the EHU and CD changer connections. I'll give it another go later today. I'm wondering if a dead Amp2 can also cause a total system failure
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #4 ·
Update! For a brief second I saw the laser on the plug that goes to the CD changer, but as soon as I plug it into the changer, it goes away. So I'm wondering if either my changer, or EHU is faulty. Anyone else had this issue and have a fix?
 

·
Registered
Joined
·
11,383 Posts
You have bad CD changer. You can bypass fiber, plug red blinking fiber (connector pin 1) direct to ICM (pin 1).
Connector pins are marked with triangle pointing in (pin 1) or out (pin 2).
 
1 - 8 of 8 Posts
Top