SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a question concerning the intermittant operation of my soft top on 2000 9-3. It seems that sometimes it will partially open than give soft top failure. Two things seem to allow soft top to open further 1. move switch on console again or 2. manually push up on front of top while moving switch. When trying to close\raise top the cover opens but top does not raise or if it does, it moves slowly. If I pull up on top while operating the switch it will start to raise and then continue to close on its own. Any help appreciated. Daae Harris, Millersville, PA
 

·
Registered
Joined
·
2,945 Posts
soarntz, welcome to Saabcentral!

There's a forum for the pre-2004 verts over here.

I'm going to move this thread over there so the nice friendly helpful folks can take a whack at your problem!
(Wow, 2 in 1 day. Must be Summer!)
 

·
Registered
Joined
·
434 Posts
Check your hydraulic fluid, my mechanic told me to check this along with my microswitches to make sure the piece on them are being triggered correctly.

He said he rarely sees any other problem like the older motors blowing.

-Avinash
 

·
Registered
Joined
·
434 Posts
http://www.thesaabsite.com/93/93faqs.htm

Read under the Body Category and check your stuff man, the only way I recommend check is to have someone else do the switch while you monitor everything and stay clear of moving parts :)

If it IS hydraulic fluid, you've have to top that off with 10W jack fluid or fork fluid for bikes.

-Avinash
 

·
Registered
Joined
·
98 Posts
does it make a grating cog type sound??

if it does i had this problem on a 900 cabriolet
its the lifting actuator cogs misaligned

i wacked mine whith a hammer and got it to work and the cogs meshed in corretly
saab said i couldnt take the motor out and then fit it as it requires a computer set up buit all i now is it saved me like 1500 pounds at the dealership and a i sold it soon afterwards still fully working
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
It does not make any unusual noises... I'm am going to try to check the Hydraulic Fluid issue this evening. Thanks, Dave
 
1 - 6 of 6 Posts
Top