SaabCentral Forums banner
1 - 20 of 25 Posts

·
Registered
Joined
·
3,092 Posts
Discussion Starter · #1 ·
Everything is falling apart.

Don't usually do this, but I've reached a point where I'm getting really fed up with the car.

Ever since my warranty is up, I feel like the car is falling apart - it has only been 2 months. At this moment, there is a serious love/hate relationship between the two of us, and at the moment, leaning towards the latter.

Every other day, some new problem comes out of nowhere :evil: I've always had a loud metallic noise come from the front end when hitting sharp road imperfections, but it wasn't really too loud. I mentioned it to my dealer and he "fixed" the loose heat shield. Obviously that didn't fix the problem and the problem still exists. I read numerous threads about metallic clunking noises, but I thought it was the good old Saab front end.

Today after a longer than usual trip my car developed a combo of issues.

First, when accelerating, as soon as the tach hits near the 40mph mark, the car shivers and is sort of vibrating. This only happens under load (not full load though) and only in 2nd gear it seems. I'm so anal about this car that even a few weeks back I thought I felt a very very slight vibration in the entire car when slightly accelerating in 2nd specifically. I thought to myself it's probably the road and I shouldn't be too worried. Well I was wrong, and this vibration seems to have gotten much stronger as of today. The car vibrates quite a lot and the power delivery is anything but smooth to a point where I try to avoid that rpm/speed range.

So now I'm really ticked off because I have a feeling this will not be some easy fix and it will most likely cost me. I'm just praying it's not something big :evil:

After that, I then get off the highways and start hitting the small city roads. I now notice that whenever I hit any sharp road imperfections I hear that loud metallic loose noise mentioned above but MUCH, MUCH louder (windows down), as if something is going to fall off. At one point, the passenger next to me had a WTF look on his face so I asked him if he heard the noises, and he said clearly.

I really don't know what suddenly happened or if the two issues are somehow related together but the first thing that came to mind was the motor mounts? The car has just over 40K miles and was last at service not even a month ago where they under "good will" changed out my worn strut mounts and bearings because I was just OOW.

So with this little trip (400km) my car developed two problems and I'm furious as these things just ruined my entire trip (Bungee jumping, which was great btw).

As I was driving back home (sun setting) already pissed off, I noticed that my front left beam was shooting quite low. I get home and turn off the car, and then turn it back on and only my right headlight adjusts and my left one just stays pointing downwards :evil: No error message, nothing :roll:

I treat this car so well to a point where my gf and friends think I am quite weird. Always followed the maintenance, service, and changed oil way before the suggested intervals. I have put so much time and money into it to make it “mine“ but I feel I have been let down. Maybe I am over reacting a bit, but all these problems in no time makes me not to want to trust this car and invest money into it. I will be leaving the country in 1 month and I love this car so much that I will be shipping it with me back home (6K miles) - that is how much I am attached to it, but I am starting to get doubts.

So there you have it, my little rant. I really needed to get this off my chest and if you read the whole thing, thank you. If you have any suggestions, then they are welcome as well :cry:
 

·
Registered
Joined
·
691 Posts
Heyyyy dude.... i read all your msg.... damn.. not cool to hear.. but... maybe its not a big thing your problem... what about the motor mount? maybe look like this as your describe it...

For the adjustment of your beam.. dit you try to disconnect the batteri and reconnect after?.. something my car act weird and i do this and its fix the problem (like my window that doesnt want to close last summer...

I know you love your car.. i love mine too and drop 4k$ to repair the **** engine because my 4th cylinder was almost dead... it was pissed me off but... i love this car.. and any other car that is not under warranty will have some trouble..

Just dont discourage you and take a beer and tomorrow is an other day:p
 

·
Registered
Joined
·
129 Posts
Wow.. I hear you, especially when issues keep on adding up! I say tough it out a bit, can always be an easy fix you know?

I have an issue with the Top mount bearings. Are you sure it wouldn't be the same for you? I have that loud clunking noise as well.

Hope it all works out for you!
 

·
Registered
Joined
·
1,097 Posts
about the shimmy during acceleration, does it only do that when the car is tuned?
 

·
Registered
Joined
·
3,092 Posts
Discussion Starter · #5 ·
Thanks for the encouragement guys. Today is a new day, and I'm looking at it differently.

So the shudder is still there. Again it still seems to be doing it only in 2nd gear and if I'm not mistaken when warm - this worries me a bit. Even though it happens in a specific gear/speed, could it be my tires? I'm tempted to slap on the front 17"s and go for a test drive, but a lack of a proper jack and work space prevents me to do so.

The suspension clunking seems to have quietened down as well, so now I'm back to the good old faint metallic clunking. My dealer apparently changed the strut mounts AND bearings last time the car was in for service so I'm not sure that's the problem

As for the auto level headlights, it's now intermittent and does not always do it. They sometimes level, and other times won't. The battery is disconnected as we speak, so hopefully that will cure this issue.

I'm going right now to test if the car does this shimmy when not tuned. I will also try with Rev 1.0 (old tune) and see if it allows me to do so.
 

·
Registered
Joined
·
773 Posts
Does the shuddering feels like a shopping cart that has one wheel just barely touching the ground and it wobbles/vibrates as you walk?
 

·
Registered
Joined
·
235 Posts
Not sure how it is in the Great White North - seeing as how you mentioned the strut mounts/ bearings - but here, I received the notice from Saab about the front suspension being "recalled" if under 120K and one/both of your springs break. Spring issue perhaps and not just the mounts or the bearings? Either way - we all hate to hear about major issues with ANYONE on here - good luck, man.
 

·
Registered
Joined
·
3,092 Posts
Discussion Starter · #8 ·
Yeah you can say it vibrates/shakes like a shopping cart.

I have after market springs/shocks - one of the main reasons I put those on was to get rid of the freaking noises our crappy suspension does. Unfortunately, that didn't solve the problem.
 

·
Registered
Joined
·
3,092 Posts
Discussion Starter · #9 ·
Just came back from a drive trying all the tunes - stock rev 1 and 2. They all exhibit the same shaking symptoms.

It took the car a while for it to develop the vibrations, it seems it needs to be quite hot. When I first took the car out, there was no issues at all. As it got hotter, the symptoms came, and still I wasn't able to replicate it every single time.

Thing is, now I'm unsure if this vibration is sort of a hesitation and lack of power. I was able to hold it in 2nd gear around that mark and pressing and then letting go, and pressing and letting go, i felt the car was struggling while it's shaking.

Could it be the infamous V6 coil pack on the way out or already out?
 

·
Registered
Joined
·
129 Posts
What about the lights?

Really guys? Coil Pack would cause vibrations? I'd really think it'd be more a suspension related thing...Come to think of it I have that same problem when I first get the car on the highway.. I have what feels like an alignment out of tune right until the car gets hot enough and then drives fine...
 

·
Registered
Joined
·
5,873 Posts
What about the lights?

Really guys? Coil Pack would cause vibrations? I'd really think it'd be more a suspension related thing...Come to think of it I have that same problem when I first get the car on the highway.. I have what feels like an alignment out of tune right until the car gets hot enough and then drives fine...
Without a doubt. A bad coilpack would be no spark and if you've ever had a cylinder misfiring or not firing there is a bad shake and vibration.
 

·
Registered
Joined
·
1,851 Posts
it could be the Vtuner relating issues........

I have not used the warranty, only replaced the expansion tank and not more problems or minor issues.
 

·
Registered
Joined
·
3,092 Posts
Discussion Starter · #14 ·
Well I tried with the stock tune and the vibrations are still there, so it doesn't seem to be vtune related.

As for the coil packs, I will be ringing up the dealer come Monday and I will mention that. Is it easy to tell if a coil pack is out? Wouldn't the shuddering be more like jolting and power cutting off power?

It's like my car refuses to throw out any CEL's or error messages. Even after the initial battery pull, my left head light still intermittently does not adjust the lights and throws no error message :cry: So to answer your question, no CEL. My plugs are about 40k miles old.

For the person that suggested suspension issue it could be that as well considering my mechanic told me I most likely have a defective Koni front right shock. Thing is, unless the shock is getting progressively worse, I'm not sure if it's the front setup. I have a shock on order and hopefully it will come soon enough.
 

·
Super Moderator
Joined
·
20,436 Posts
Sounds like a coil pack to me too. There should be some misfire codes stored for the dealer to see.
 

·
Registered
Joined
·
46 Posts
Sounds like a coil pack to me too. There should be some misfire codes stored for the dealer to see.
Just wondering - If it's a coil pack issue is it reasonable that it would only affect a specific gear?

I'd expect he would have the same type of vibrations consistently throughout each gear at specific revs.

Vector, I'm taking my car in to address the "crunching" and metallic chirp tomorrow, I'll let you know what they find (or dont find).
 

·
Registered
Joined
·
3,092 Posts
Discussion Starter · #17 ·
UPDATE:

After going for a test drive with my mechanic he was able to feel the vibration/shudder. Also he heard the metallic clunking coming from the front end of the suspension. I also had mentioned my A/C makes a LOUD noise when first started, at times, it takes even around 6 minutes to start blowing cold air (warm start), before the alternator even starts. Even the tech agreed that it does not sound normal at all.

I get a call from the dealer and they tell me the vibration is from my welded BBS wheel, which I've been riding on for years now. They also tell me they balanced the wheels, and it's less the vibration (non sense). I believe this has nothing to do with the wheels as it happens only in 2nd gear at 60km/h and ONLY when the car is extremely warm. They mention there are no vibrations coming from the transmission or engine.

Onto the metallic sounds, again, the mechanic heard the noises when we test drove the car, however when it went in the work shop, they said "we didn't hear anything from the front end."

NOTE: Everyone who has a metallic clunking from the front end check your brakes. Reason is, when I apply the brakes when going over bumps/cracks the car is whisper quiet. I mentioned that to them, but again, they did not do a damn thing and they said the brakes are fine.

Finally, for the AC they told me they got the "AC specialist" and he said it's normal and all other 9-3's sound the same :evil::evil::evil: NO THEY DO NOT. This sounds like a jet taking off.

Anyway, my car basically went in for nothing, a waste of time, waste of money, and they piss the crap out of me. I was so furious that I told me service advisor "I'm coming to pick my car up, pay my bill, and never ever return to you guys. You've wasted my time, money and you refuse to fix anything. Thank you very much."

The car has been into the garage for at least 4 issues where they never fix a thing and they keep telling me "it's normal." I've been driving a 9-3 for almost 7 years now and I believe I know what is normal and what is not.

Why do they take me on test drives, tell me "yeah it's not normal, and then when the car goes into the garage they tell me it's normal"??

I'm actually so angry right now, that I would like to file an official complain to Saab. I'm located in Montreal, Canada. Anyone can give me an email address where I can unleash my fury? Thanks
 

·
Registered
Joined
·
691 Posts
UPDATE:

After going for a test drive with my mechanic he was able to feel the vibration/shudder. Also he heard the metallic clunking coming from the front end of the suspension. I also had mentioned my A/C makes a LOUD noise when first started, at times, it takes even around 6 minutes to start blowing cold air (warm start), before the alternator even starts. Even the tech agreed that it does not sound normal at all.

I get a call from the dealer and they tell me the vibration is from my welded BBS wheel, which I've been riding on for years now. They also tell me they balanced the wheels, and it's less the vibration (non sense). I believe this has nothing to do with the wheels as it happens only in 2nd gear at 60km/h and ONLY when the car is extremely warm. They mention there are no vibrations coming from the transmission or engine.

Onto the metallic sounds, again, the mechanic heard the noises when we test drove the car, however when it went in the work shop, they said "we didn't hear anything from the front end."

NOTE: Everyone who has a metallic clunking from the front end check your brakes. Reason is, when I apply the brakes when going over bumps/cracks the car is whisper quiet. I mentioned that to them, but again, they did not do a damn thing and they said the brakes are fine.

Finally, for the AC they told me they got the "AC specialist" and he said it's normal and all other 9-3's sound the same :evil::evil::evil: NO THEY DO NOT. This sounds like a jet taking off.

Anyway, my car basically went in for nothing, a waste of time, waste of money, and they piss the crap out of me. I was so furious that I told me service advisor "I'm coming to pick my car up, pay my bill, and never ever return to you guys. You've wasted my time, money and you refuse to fix anything. Thank you very much."

The car has been into the garage for at least 4 issues where they never fix a thing and they keep telling me "it's normal." I've been driving a 9-3 for almost 7 years now and I believe I know what is normal and what is not.

Why do they take me on test drives, tell me "yeah it's not normal, and then when the car goes into the garage they tell me it's normal"??

I'm actually so angry right now, that I would like to file an official complain to Saab. I'm located in Montreal, Canada. Anyone can give me an email address where I can unleash my fury? Thanks

Damn its realy gay!!1
Where do you went?

My car still at the dealer.. second time i have a broken piston within 3 month... NOT NORMAL!!! they said it was my air intake (got it for more then a year.. why doesn everything broke now like 20-30000km later?
Now im trying to get the JE forged piston to replace them.. and they told me that my intake will be fine after because the Forged piston will be strong enaugh....
WTF.. I dont like when they treat us like stupid kid...

Im in with you for the letter ;oops:.. after spending around 7K$ for stupid **** like that...
 

·
Registered
Joined
·
3,092 Posts
Discussion Starter · #20 ·
Damn its realy gay!!1
Where do you went?

My car still at the dealer.. second time i have a broken piston within 3 month... NOT NORMAL!!! they said it was my air intake (got it for more then a year.. why doesn everything broke now like 20-30000km later?
Now im trying to get the JE forged piston to replace them.. and they told me that my intake will be fine after because the Forged piston will be strong enaugh....
WTF.. I dont like when they treat us like stupid kid...

Im in with you for the letter ;oops:.. after spending around 7K$ for stupid **** like that...
Exactly, they do seem to treat us as "little kids." I went to Saturn Saab Cadillac De Laval. I can only say good things about my service advisor (Jean-Cederic) as he's extremely helpful and polite, but the mechanics in there either have absolutely no idea what to do, or they plain and simply don't want to work.

That sucks about your pistons. Hopefully you can get it sorted out. If Saab wants a new strong beginning and a successful one, well, they better get working because the service is absolute crap up here in Montreal.
 
1 - 20 of 25 Posts
Top