SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,887 Posts
Discussion Starter #1 (Edited)
i installed an aftermakret headunit in my '95 900se got the harness adapter for the radio, and bypassed the stock amp for the door speakers. the radio all works fine and sounds great. but now my sid only displays the outside temperature, sometimes it will flash a whole bunch of horizontal dashes for a split second, and when i switch to see what my fuel mileage, DTE or anything else is it appears as if i just cleared everything. and sometimes the backlight on the small analog clock does not come on. is this because i removed the stock radio? or might i have loosened some connection on the back of the sid?
 

·
Registered
Joined
·
10,382 Posts
It's because you have something connected to one or both of the pins that the car uses for the information bus between the radio and the SID. Unplug your radio and look for the two differently colored pins in one of the radio plugs. Those are the bus pins and they can't have anything connected to them.
 

·
Registered
Joined
·
102 Posts
hello TurboJohnny,

Jeremy is right, I have run my car many times without the radio installed, no problem.
On the 9-3 the two-wire CAN bus also runs to the trunk for the optional CD changer.
As far as I know you do not need to terminate unused CAN bus connections.
But make sure these unused CAN bus wires are isolated and do not short or get grounded !

I don't know the colors for these bus signals in your car but take a look at
http://www.kolumbus.fi/richard.bevan/saab/saab93/fitting.html
and make sure that "BUS +" and "BUS -" are NOT connected to your new non-saab radio.


Jeremy R. said:
It's because you have something connected to one or both of the pins that the car uses for the information bus between the radio and the SID. Unplug your radio and look for the two differently colored pins in one of the radio plugs. Those are the bus pins and they can't have anything connected to them.
 
1 - 5 of 5 Posts
Top