SaabCentral Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter · #1 ·
I got a 2004 9-5 Aero (70K miles) and last night I noticed that on my display menu it wont show temperature and my AC blows only warm air. Whats the culprit of this Saabotage and how much will it cost me to fix it??? Any advice will be greatly appreciated :cry:
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #7 ·
So when I switch to temperature on my display, it shows --- :evil: It gets no reading! And I cant get the AC to blow cold air. So you guys think its the wiring to the temperature censor or the censor itself? Can it be a problem with my AC?
 

·
Registered
Joined
·
11,030 Posts
If the ACC display doesn't show any digits then you probably need to do the pixel repair as detailed in the FAQ's. If you have no exterior temp display on the SID then as Scott said it's the exterior temp sensor under the front bumper.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #9 ·
If the ACC display doesn't show any digits then you probably need to do the pixel repair as detailed in the FAQ's. If you have no exterior temp display on the SID then as Scott said it's the exterior temp sensor under the front bumper.
Thanks for clarification. But why my AC is not working properly??? Is the outside temperature sensor related to the AC????
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #10 ·
Just fixed this problem yesterday. It was the wiring to the censor that was corroded and needed to be replaced. My AC is blowing cold air once again :cheesy:
 

·
Registered
Joined
·
22,211 Posts
Just fixed this problem yesterday. It was the wiring to the censor that was corroded and needed to be replaced. My AC is blowing cold air once again :cheesy:
Well done ;)
 
1 - 11 of 11 Posts
Top