SaabCentral Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
433 Posts
Discussion Starter · #1 ·
About a week or so ago I lowered my car with my H&R springs (brand new.....so awesome.)

I've noticed that there is a shaking in lower RPM's that I don't understand in the slightest. My cousin is a mechanic and even he gave it a skeptical look but wasn't able to fully digest the issue as he only had a few minutes to help me with it.

Anyone have any ideas? The springs are brand new. I know the car needs to be aligned and I am taking care of that tomorrow..but just needing the alignment shouldn't send the whole car into a weird shutter at lower RPM's should it?

Any ideas or advice would be the sickness. Thanks all.
 

·
Registered
Joined
·
675 Posts
The issue might be unrelated, did you put the springs on yourself or have a shop do it?

do you have a cel?

I just put h&r springs on my car 2 weeks ago and it rides great.
 

·
Registered
Joined
·
1,033 Posts
I had a similar problem when I lowered my OG93. The issue was worn inner drivers on the drive axles.

If the inner drivers are worn, the tripod bearings have created sort of a wear pocket on the surfaces they normally ride. When you lower the car, it changes the geometry of the CV axle and the tripod bearings are constantly going in and out of the wear pocket creating the shuddering/vibrating etc.
 

·
Registered
Joined
·
433 Posts
Discussion Starter · #4 ·
The issue might be unrelated, did you put the springs on yourself or have a shop do it?

do you have a cel?

I just put h&r springs on my car 2 weeks ago and it rides great.

My cousin and I put them in, but that is the least of my worries. I've lowered cars before and my cousin has been doing this stuff since he was like 3. He's been through Baron Institute as well, so knowledge on lowering isn't the case I hope. I appreciate your feed back though. I'm glad your car rides so nice! Looks absolutely awesome doesn't? H&R lowers to a reaaaallly nice spot.
 

·
Registered
Joined
·
433 Posts
Discussion Starter · #5 ·
I had a similar problem when I lowered my OG93. The issue was worn inner drivers on the drive axles.

If the inner drivers are worn, the tripod bearings have created sort of a wear pocket on the surfaces they normally ride. When you lower the car, it changes the geometry of the CV axle and the tripod bearings are constantly going in and out of the wear pocket creating the shuddering/vibrating etc.
How common of an issue is this? Is this something I should be concerned about? If so, how can I go about fixing said issue?
 

·
Registered
Joined
·
1,033 Posts
If it is the culpirt, I would have them changed out. The shaking is highly annoying at least in my case.


A quick look on thesaabsite.com shows the inner driver being around $250 or so.

http://www.thesaabsite.com/93/93cvs03on.htm Part #8 on the diagram of the whole CV axle.


My suggestion would be to find used CV axles from a junkyard
 

·
Registered
Joined
·
208 Posts
About a week or so ago I lowered my car with my H&R springs (brand new.....so awesome.)

I've noticed that there is a shaking in lower RPM's that I don't understand in the slightest. My cousin is a mechanic and even he gave it a skeptical look but wasn't able to fully digest the issue as he only had a few minutes to help me with it.

Anyone have any ideas? The springs are brand new. I know the car needs to be aligned and I am taking care of that tomorrow..but just needing the alignment shouldn't send the whole car into a weird shutter at lower RPM's should it?

Any ideas or advice would be the sickness. Thanks all.
Are your shocks still oe?
 

·
Registered
Joined
·
31 Posts
I get a small drown / vibration on my Aero after its been lowered. It only seems to happen when accelerating in 3rd 4th or 5th at speeds above 55mph. Its not a wheel balance or tracking problem.
 

·
Registered
88' SPG, 03' 9-3 2.0T
Joined
·
771 Posts
Let me bring back this thread from the grave.. :roll:

After lowering the car on vogtlands/koni yellows (about 2 months ago), car developed a subtle vibration at idle in gear and I'm also quite sure the passenger side axle has worn out due to changed geometry (I will check and confirm this for sure over the weekend). To all of you guys with the 5spd auto box that are lowered - what's your take on this? I know I need new axles and possibly inner drivers, but what's the long term solution? Are custom fabricated engine mounts to raise the engine ~1.5" the only way out? Anyone else out there experienced this recently?
 

·
Super Moderator
Joined
·
20,432 Posts
My car has been lowered for 4 years or so and 30-40k miles. No issues. 5 speed auto.
 

·
Super Moderator
Joined
·
9,708 Posts
Both my 2009 and 2008 did/do what the OP describes. Didn't matter whether it was Konis, Eibachs, or KW coilovers. I heard from my dealer shop foreman that all NG9-3s do this when lowered. I'm pretty sure it's something in the rear, not the front. It only happens at around 15-25mph and then it disappears. If you you're not OCD or attentive to detail you'd never notice it. Doesn't bother me anymore, and we all know how crazy I am.

Anyway, adwarp, your issue sound entirely different. Vibration at idle, correct? Not while in motion?
 

·
Registered
88' SPG, 03' 9-3 2.0T
Joined
·
771 Posts
Both my 2009 and 2008 did/do what the OP describes. Didn't matter whether it was Konis, Eibachs, or KW coilovers. I heard from my dealer shop foreman that all NG9-3s do this when lowered. I'm pretty sure it's something in the rear, not the front. It only happens at around 15-25mph and then it disappears. If you you're not OCD or attentive to detail you'd never notice it. Doesn't bother me anymore, and we all know how crazy I am.

Anyway, adwarp, your issue sound entirely different. Vibration at idle, correct? Not while in motion?
Yep, it only vibrates while at a complete stop and in gear. Does it in manual mode and in reverse also. I've ruled out all the mounts and the engine is smooth in every other situation. I'm 99% sure it's the inner drivers, since that's where the stress is while in-gear and foot on the brakes. I can also hear a tick when I press the gas pedal after letting off (at all speeds but not always). Transmission shifts smooth otherwise, after the ATF drains/fills few months back. I can also hear noises on the right side while turning hard left, which I'm suspecting is the cv axle. Another thing, very occasionally, on hard acceleration (above 45mph and 3-4-5th gear) the car will "jump" for the lack of a better term. As if it wanted to come out of it's shoes. I can feel it in the axles area.

Overall, I'm not too annoyed by the vibration. Just wanted to see if anyone else had similar problems after changing the axles' geometry. I know on other slammed cars, the axles tend to break after dropping them. Anyways, I will have to investigate this on jack stands over the weekend. Hope it's just a freak of nature and new axles will solve this nonsense. :evil:
 

·
Super Moderator
Joined
·
9,708 Posts
Yep, it only vibrates while at a complete stop and in gear. Does it in manual mode and in reverse also. I've ruled out all the mounts and the engine is smooth in every other situation. I'm 99% sure it's the inner drivers, since that's where the stress is while in-gear and foot on the brakes. I can also hear a tick when I press the gas pedal after letting off (at all speeds but not always). Transmission shifts smooth otherwise, after the ATF drains/fills few months back. I can also hear noises on the right side while turning hard left, which I'm suspecting is the cv axle. Another thing, very occasionally, on hard acceleration (above 45mph and 3-4-5th gear) the car will "jump" for the lack of a better term. As if it wanted to come out of it's shoes. I can feel it in the axles area.

Overall, I'm not too annoyed by the vibration. Just wanted to see if anyone else had similar problems after changing the axles' geometry. I know on other slammed cars, the axles tend to break after dropping them. Anyways, I will have to investigate this on jack stands over the weekend. Hope it's just a freak of nature and new axles will solve this nonsense. :evil:
Gotcha. Keep us posted!
 

·
Registered
Joined
·
5,468 Posts
Remember that aftermarket/reman axles tend to be worse than used OEM in good shape.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1 Posts
Hi all,
lowered my 20.000 km m/10 Aero convertible last week, got shakes/vibrations, :( in low speeds, when accelerating, so I will follow this thread with big interest.

2,0t biopower with 5-speed automatic.
Changing the cv-joints isn't even close to cheap :confused::roll:

Anyone who has tried and knows if raising the engine in the back, like at the older ng900/OG9-3 cars, will help this out? The old cars was raised just e few mm, lika 5-6 mm. Ist it even possible on our cars? And how?
 

·
Registered
88' SPG, 03' 9-3 2.0T
Joined
·
771 Posts
Another thing, very occasionally, on hard acceleration (above 45mph and 3-4-5th gear) the car will "jump" for the lack of a better term. As if it wanted to come out of it's shoes.
Well, a little update on all this. Took a road trip from Chicago to Miami and back, 3000 miles total. Car performed well, although I never gun it, especially since those previously mentioned issues. Average mileage per gallon at 36, and that's including major traffic delays on the way and some city driving.

Now to the point. Upon return, I finally decided to tackle the issues. Car started sputtering a little harder lately, so I checked the plugs and bam - 3rd cylinder spark plug valley full of oil. To the point, that the plug is soaked in it and there's some oil on the coil also. Not good. Ordering new valve cover gasket, which should fix the issue.

At least I got the sputtering pinpointed. Should've checked everything more thoroughly before going on a road trip - stupid me. I believe this issue could also be related to the slight vibration I'm getting at idle. Transmission still ticks occasionally when shifting to Park or Reverse. Axles appear to be good after all. I reused strut bearings when putting in Koni's, and sure enough it's the bearings making noise.

Looks like another summer full of repairs. Fun times! :roll: :evil:
 
1 - 20 of 21 Posts
Top