SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3,701 Posts
Discussion Starter · #1 ·


I'll need to wait until I can get the car off the road for a day or two to install these, and the Koni/B&G kit I have, as well as some other stuff.
 

·
Registered
Joined
·
2,284 Posts
Give serious thought to painting it with anti rust coating before install, they rust real fast, mine I sprayed with clear lacqour and it still rusted fast.

Also mind not to over-tighten the front drop link bushes, very little is needed.
 

·
Registered
Joined
·
3,701 Posts
Discussion Starter · #3 ·
Give serious thought to painting it with anti rust coating before install, they rust real fast, mine I sprayed with clear lacqour and it still rusted fast.

Also mind not to over-tighten the front drop link bushes, very little is needed.
Thanks for the paint advice. I'll give it a try.

Do you mean something like POR-15, or will anti-rust spraypaint work?
 

·
Registered
Joined
·
3,701 Posts
Discussion Starter · #4 ·
Give serious thought to painting it with anti rust coating before install, they rust real fast, mine I sprayed with clear lacqour and it still rusted fast.
How long ago did you buy them from SAS? As I look at them now, they are either covered in a goldish paint, or are galvanized with some sort of coating. I'm no expert though.
 

·
Registered
Joined
·
2,284 Posts
How long ago did you buy them from SAS? As I look at them now, they are either covered in a goldish paint, or are galvanized with some sort of coating. I'm no expert though.
Bought mine 7 years ago, came with the same goldish paint, not certain what the best approach is, need to decide as I have a second set arriving soon. Tempted to bare metal them and prime and paint with just decent metal paint, anything is better than that gold paint which might work well in say Death Valley.
 

·
Registered
Joined
·
2,977 Posts
I just fitted mine front and back, the front ones are a pain in the A### and IMO badly bent, the bushes don't line up on the straight section and clamp onto the bend which distort the poly bush. The drop link set up is really poor and the poly bushes have a habit of disappearing...I assume they split and fall off. You need to throw the supplied ones away and modify drop links with a proper diameter stainless bolt and poly bushes that fit the standard arb setup.
See link of my post on uksaabs..

http://www.uksaabs.co.uk/UKS/viewtopic.php?f=3&t=86047
 
1 - 6 of 6 Posts
Top