SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 2006 (80K miles) Saab 9-3 typically idles at 900 RPM smoothly. Recently it has been sporadically dropping to 600 RPM at stops (but sometimes it stays at 900). Over the last couple of days on two occasions, the drop to 600 nearly caused the engine to stall but the engine "caught" the stall. At 600 RPMs the idle is rough and causes vibrations.

I asked a dealer to check this problem out when I got an oil change and they said they could not replicate the problem and saw no issue.

Has anyone ever experienced this or have any knowledge of potential causes? I don't want to put too much money into this car.
 

·
Registered
Joined
·
435 Posts
Search for "vacuum hose" within this forum. That is the classic symptom of a vacuum leak, and its a pretty easy fix.
 

·
Registered
Joined
·
1,395 Posts
Yes, on my Aero there is a plastic type vacum hose located on the back of the engine, very high up, just under the plastic cover that broke at the one way valve. It also made my breaks a bit soft as it causes a large vacum leak. You can replace the entire "y" shaped vaum line network, or use some 5 minute epoxy like I did....


Sean
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Just heard from mechanic. He said there was no vacuum leak. He cleaned the throttle and spark plugs--said they were dirty. Is this mechanic speak for "there is nothing wrong" or might this have been the cause?
 
1 - 6 of 6 Posts
Top