SaabCentral Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello Everyone
I am gland that I became a member of this forum and its sad that my first post has to do with a problem with my car.

I dont know why but every time I am driving with 60km/h and I need to stop the car(due to traffic or traffic light) I start by pressing the braking pedal and then when near stopping I press the clutch and the rpm drops to 200-300 and the car engine stops. This doesnt happen when I am driving in a traffic jam with many start-stops though. It happened to me 3 times today and another 2 yesterday.

Anyone has any ideas about what could be the problem?
Also can the problem be related with another problem that I have with the speedometer to be stuck on 0km/h

Thanks in Advance
Antonis SX-AKO
 

·
Registered
Joined
·
953 Posts
Try cleaning the IAC valve. You can do this in-car on a running engine. Remove the 90 degree silicone elbow on the throttle body. On the inside bottom of the throttle body will be a port.

Spray throttle body cleaner or similar into this port and it will be drawn through the IAC valve. After cleaning you may want to add a bit of ATF or similar to lubricate the valve. Be very careful to avoid using any chlorinated compounds.
 

·
Premium Member
Joined
·
3,012 Posts
Okay, so you have a MY96 9000CD 2.0 5sp

So..your speedometer doesn't work and you stall out when coming to a stop above 60 kmh but not when in stop and go traffic?

I would look for vacuum leaks...especially check that your IC pipe couplers are secure. Clean your AIC valve.
 

·
Registered
Joined
·
13,491 Posts
I wouldn't reveal this secret to anyone but a fellow Greek.
After you've checked for vacuum leaks, try cleaning the throttle body with solvent. It's cheap and easy.
Where in Athens do you live?
 

·
Registered
Joined
·
253 Posts
Also can the problem be related with another problem that I have with the speedometer to be stuck on 0km/h

Yes, they are related.
The trionic ecu needs the signal from the speedo sensor, if that is missing one of the usual symptoms is stalling when coming to a stop.

Check the sensor, it is located in the gearbox near the differential. Remove it, turn on the ignition, twist it by hand while looking at the speedometer. When the needle does not move the sensor is bad or the wiring.
If the speedometer needle does move when you turn the sensor wheel there is no drive to it. Caused by a worn sensor gear or in the worst case the internal gear in the gearbox is broken.
 

·
Registered
Joined
·
3,938 Posts
My 97 ran fine with a broken speedo drive.

The crank position sensor may be filing but I'd check for a dirty throttle plate, dirty AIC valve or vacuum leak first. The hooter valve leaking or the PCV valve failing can give these symptoms. Vacuum leaks are hard to trace.

If the engine idles fine when you remove your foot from the brake pedal then the vacuum line to the brake power booster may be leaking.
 

·
Registered
Joined
·
2,026 Posts
Could the problem have to do with proper operation of the clutch?

Maybe the clutch isn't completely dis-engaging the engine from the transmission. If that were the case, and the car is brought to a stop while in gear, the engine will bog down and stall.

Does the same thing happen if the car is brought to a stop and the gear shift is in neutral?

Maybe the reason it doesn't happen in traffic is because you are constantly pumping the clutch.

It's a long shot - but just another thing to consider.
 

·
Registered
Joined
·
3,938 Posts
Also, just before it stalls if you try to select neutral is the gear shift a little stuff, inidicating clutch drag. Air in the clutch line is a common problem. Also, if this gets worse in hot weather it may be air in the clutch line.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #16 ·
Problem Solved

The problem was solved by cleaning the butterfly of the acceleration and the valve of the idle( not sure if these are the correct translations.;ol; It cost 45 euro at the official saab service station.
About the speedometer thought the told me that the gearbox needs to disassembled, fix the issue and then re-assembled. total cost fo 650 euro:(.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top