SaabCentral Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
Can you help me out please.

Not sure which engine or stock turbo (maybe td04hl-15t ????) is in this car, but at 8000' elevation the turbo stopped working. I've been up to 11k before OK. No noise, no smoke.

In the attached video I switched out some parts and checked the vacuum lines (new about a year ago) and all hoses and clamps for leaks or cracks but all appear in good shape.

I have not done a smoke test.

The waste gate is opening and the turbo spins by hand with maybe some slack.

See video.
 

·
Registered
Joined
·
8,454 Posts
You need to secure wastegate rod. If it pops up, you will have P1105 DTC.
 

·
Registered
Joined
·
7,839 Posts
I've got a couple of leftover extra BPC's. you can have one for the cost of shipping. PM me if you want one.

Also, check the wiring to the BPC, I found mine frayed that was causing a lack of boost. That part of the harness runs along the engine and can get damaged due to all of the heat cycles.
 

·
Registered
Joined
·
7,839 Posts
Happy Thanksgiving

Here's the boost gauge video
Does it tell you what's next?

TY

you won't often see huge boost in this car unless there is a load on the engine. (so take it for a ride and stomp on it while the car is in gear and moving)

The "boost" gauge on the T7 systems is really a reflection of engine load, and while the car is in neutral there is no real load (and the ECU knows that) so it doesn't boost since it doesn't have to.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #11
Noted. When driving hard that's all it does, the engine has little power and no boost beyond these levels in this video.
 
1 - 11 of 11 Posts
Top