SaabCentral Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Over the past months I have had ongoing issues, where the car between 1000 - 2000 rpm will not run smoothly it chugs and slightly misfires get P0314 DTC code. above 2000rpm the car is fine. basically if i 'm accelerating its fine but when trying to hold 30mph or 50mph and the rpm is at around 1500rpm the car pulls then holds back and is just not smooth. I have replaced the intercooler hoses as there was some small possible leaks. I then noticed the vacuum hoses were not connected as per the WIS, so i replaced them all and connected them as per WIS and also added a non-return valve again as per the WIS which was previously missing, and plugged the left side of the vacuum tank. now i get full top end performance great but the problem still exists it is still misfiring. after many hours of testing i have found that the Swirl Flaps vacuum diafram is operating fully at idle which im presuming is closing the flaps which is correct i believe. However if i disconnect the vacuum and plug the pipe so the flaps are open contently, then the car will run fine, no misfires can drive it at 30mph no issues and have all performance. so i can only presume that their is an airflow issue on the intake manifold when they are closed. Question is before i take the intake manifold apart to inspect them has anyone else had this issue, as i can only find googling, issues where the swirl flaps are not closing causing bad running and mine seems to be the otherway around if they are closed the car does not run. Could this be down to carbon build up on the intake manifold not allowing air flow? will leaving them fixed in the open position cause an issue?

any advise welcome
 

Attachments

1 - 1 of 1 Posts
Top