SaabCentral Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I've been ghosting this forum for a while to figure out things when my saab messes up, but I'm stumped and can't find a thread to help me.

About 2:45 am Sat morning i went to start my car and all it does is one click. No SID message (other than the one thats been there since forever and it's for the window wiper fluid), but the engine light stays on. No lights flicker, everything (radio, A/C, etc) works. I have changed the battery, checked the fuses, checked the wires running to the starter and just today changed the starter so i know it's none of those things. My question is what else could it be? Not the CPS as the engine wasn't hot to begin with (unless it failed completely?)

I've no ideas left! :evil:
 

·
Registered
Joined
·
116 Posts
Sorry to hear of your troubles. For a case like this, you need a code reader to read the engine's codes. They have inexpensive stand-alone ones as well as good smartphone apps. That will give you some clues about what's awry.
 

·
Registered
Joined
·
1,053 Posts
try jumping the ignition relay R8 to isolate the problem fore or aft of the front bulkhead. If you get a connection and engine turnover you know the problem is in the cockpit. Most likely then would be ignition module needs cleaning or replacement. Other less likely possibilities would be the CIM or key fob.
 

·
Registered
Joined
·
980 Posts
If the engine won't even crank over, it's definitely not the CPS. Check the circuit breaker connected to the positive battery post if your car has one. I believe the 2003's do have them but they were removed in later years.
 
1 - 4 of 4 Posts
Top