SaabCentral Forums banner
1 - 9 of 9 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
hi guys !
I've had an intermittent issue with my saab not starting , not only will it not start I literally have nothing ... no lights no clicking nothing ! sometimes it'll day like this for days then you can try it randomly and it'll start first turn of the key. the battery is strong and I've had it checked, it'll keep working for works then randomly play dead.
any ideas ?
I seem to remember reading somewhere it's quite common and a quick swap of relay can solve the issue but I can't find that information now 馃........
 

Super Moderator
Joined
10,038 Posts
TC module is a known non start issue on the V6,next time trying to start push on the connector..
 

Registered
Joined
11,790 Posts
Hi and welcome.
First: There is NO 2005 V6 9-3. Your car is my 2006.
Do you have manual or automatic?
If automatic, check NSS also.
 

Registered
Joined
11,790 Posts
I do not care about their silly dishes at all.
Brits should use common names.
 

Registered
Joined
3 Posts
Discussion Starter · #7 ·
Hi and welcome.
First: There is NO 2005 V6 9-3. Your car is my 2006.
Do you have manual or automatic?
If automatic, check NSS also.
registration is 55 plate . its a manual.
I do not care about their silly dishes at all.
Brits should use common names.
wow ! thanks for all your help . I'm sure you are a wonderful asset to this group and indeed to the world , thanks again for your insightfulness and willingness to help a new member with a problem . kudos.
 

Registered
Joined
424 Posts
I do not care about their silly dishes at all.
Brits should use common names.
The 55 plate car I brought from the UK now has incorrect paperwork showing it as a 2005 even though it is a 2006. I wasn't paying careful attention at the time and now it's definitely not worth the trouble to fix it. Sometimes I forget what year it is actually made. 馃槀
 
1 - 9 of 9 Posts
Top