SaabCentral Forums banner

1 - 20 of 39 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hi. My Saab alarm started going off in the middle of the night and I was not able to stop it with the remote control key. It is quite annoying and after checking contacts and all the driver's door locks, i disconnected the driver's connectors to disable it. I read that it is possible to repair the alarm module...
The alarm module is not under the front wheels or in the back of the car...
Where is it, pleaseeeeeeee????? :confused::confused::confused:
 

·
Registered
Joined
·
675 Posts
Anti Theft Alarm System Components ( Removal and Refiiting )

Electronic ( Body ) control module.
Removal.
1) Remove the drivers side ( LHD models) lower facia panel
2) Release the locking catch and disconnect the module wiring plug.
3) Releasse the 4 clips and remove the module.

Volumetric sensor.

1) Carefully remove the cover from the rear of the front interior light.
2) Remove the switch panel cover from the interior light.
3) Release the clips and remove the sensor. Disconnect the sensor wiring plug as it's withdrawn.

Siren.

1) The siren is located behind the right - hand side luggage compartment side trim panel on some models, and behind the front bumper on others. Remove the panel or bumper.
3) Undo the 2 retaining bolts, disconnect the wiring plug and remove the siren.
;ol;
 

·
Registered
Joined
·
2,744 Posts
Hmmm im gonna have to look into this. My alarm goes off too. I believe it has something to do with my rear passenger door lock not working all the time.

Mac. You said disconnecting the door wires sensor/wires will stop it.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
Hi,

Yes but it has t be the driver's door. Otherwise, the alarm will continue working.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #5 ·
Done. From the menu, press customize button and go to alarm and choose only doors. Problem solved. It must be some sensor that went bad. Now, no more problems. :)
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #6 ·
Still going off:(
I disconnected all the doors except the drivers one and it must be there the problem. I got set the alarm for doors only.
I cleaned the lock with electric cleaning spray. I cleaned the module but no luck.

I am just desperate.

:eek:
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #7 ·
Can it be the car's battery?
I bought the car last June and it has the saab battery in it. Maybe it is the one from 2004. Maybe the battery does not work properly and that is why the alarm is going off randomly. Last two days no problems. Then, today it starts over again. I cleaned the actuator lock, but it was working fine before, anyway.

Thanks
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #8 ·
Hi. It was the car's battery.
If you alarm starts going off randomly, sometimes after 5 minutes or four hours, it is because of the BATTERY of the car that is not working properly.
I just bought a EverStart Maxx H6 CCA760 ($115) at walmart that fits in the box perfectly and everything works fine with no more alarm issues. :lol::lol:
 

·
Registered
Joined
·
66 Posts
My MY03 seems to have the exact same problem as yours. Did you ever find a solution to the problem? It is pretty ridiculous, it goes off (locked or unlocked) randomly/every 5-10 min or so, whenever the remote is within working distance. Could it be the keyfob battery? I think I'm going to remove the siren for now until a more permanent solution can be done :confused:
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #11 ·
Hi. Yes, I took the car to the dealer and they checked it for me for free. It was the front passenger locking swich. They told me ******** about not being able to get it from SAAB because they didn't have it in stock anymore. So, since i don't care about the alarm (it is a pain and who cares about it?), I told them to disable it. They did it for 150 bucks and now I am really happy. The car still lights up when you lock and unlock the car and they can leave the horn working or not with the automatic locking. The alarm, no more an issue.
I don't get the problem with these cars, the passenger door is a pain: the alarm issue, the window regulator broken and replaced too, :/
If you really want to fix it, get the switch for that door. If not, get rid of the alarm by having it disabled. Remember that my car doesn't have alarm Control Module (the little box with batteries), it is the car horn.

Take care
 

·
Registered
Joined
·
1,322 Posts
My03 does the same thing except that even with the engine running the alarm can go off. Pressing the lock button on the fob stops it.

I'm still not sure what really triggers it.... Doesn't seem to be any consistent pattern... Sometimes within 10s of locking or unlocking... Sometimes an hour....

Sent from AutoGuide.com App
 

·
Registered
Joined
·
34 Posts
Alarm Information. THanks

Anti Theft Alarm System Components ( Removal and Refiiting )

Electronic ( Body ) control module.
Removal.
1) Remove the drivers side ( LHD models) lower facia panel
2) Release the locking catch and disconnect the module wiring plug.
3) Releasse the 4 clips and remove the module.

Volumetric sensor.

1) Carefully remove the cover from the rear of the front interior light.
2) Remove the switch panel cover from the interior light.
3) Release the clips and remove the sensor. Disconnect the sensor wiring plug as it's withdrawn.

Siren.

1) The siren is located behind the right - hand side luggage compartment side trim panel on some models, and behind the front bumper on others. Remove the panel or bumper.
3) Undo the 2 retaining bolts, disconnect the wiring plug and remove the siren.
;ol;
All my alarm does is blink. I will try to find the box and assembly, check the batteries and then go from there. There is a company I know who can fix the box, but for now I will do the research and inspection and go from there. Thanks for the help. LGR
 

·
Registered
Joined
·
154 Posts
Here are the issues I am having:

1. Alarm randomly goes off.

2. My side mirror adjustment button only works for the passenger side even when you select driver's side.

3. Auto up feature on the driver's side window randomly stops working. The window won't even go all the way up when this happens. I can temporarily fix this issues by unplugging the electronics connector at the door to reset it.

Any suggestions? Could the window/lock switch be causing all of this?
 

·
Registered
Joined
·
214 Posts
Here are the issues I am having:

1. Alarm randomly goes off.

2. My side mirror adjustment button only works for the passenger side even when you select driver's side.

3. Auto up feature on the driver's side window randomly stops working. The window won't even go all the way up when this happens. I can temporarily fix this issues by unplugging the electronics connector at the door to reset it.

Any suggestions? Could the window/lock switch be causing all of this?
Seems like you just got a bunch of electrical issues. Not sure how they're correlated. I do not have the other issues you have., but what I have is this stupid alarm problem and I cannot find a solid solution, but to disable it using the Tech2 device thing for $150+? WoW!

My battery is brand new.

Also, I believe setting the alarm to doors only work for me, but it reverts back to full protect mode after restarting the car, so I have to keep setting it to door only each time I park it.

I'm about to just disconnect the horn since the car doesn't have a siren/module box.
 

·
Registered
Joined
·
154 Posts
Seems like you just got a bunch of electrical issues. Not sure how they're correlated. I do not have the other issues you have., but what I have is this stupid alarm problem and I cannot find a solid solution, but to disable it using the Tech2 device thing for $150+? WoW!

My battery is brand new.

Also, I believe setting the alarm to doors only work for me, but it reverts back to full protect mode after restarting the car, so I have to keep setting it to door only each time I park it.

I'm about to just disconnect the horn since the car doesn't have a siren/module box.
Pull fuse F24 and see if that helps. It did for me. Try that and report back. FYI, it may take a couple of on/off cycles to work. The first time I tried it, I was impatient and thought it had no effect. This will also cause the Theft System Failure message on the SID, but that's way better than my alarm going off 10 times while I'm at work.

See this thread for more info: http://www.saabcentral.com/forums/showthread.php?t=284210
 
1 - 20 of 39 Posts
Top